1 Reply Latest reply on Sep 27, 2020 5:24 PM by ZhengbaoZ_96

    Configuring Cypress-43455 in AP mode, Android mobile keep disconnecting from AP

    YaBh_4672321

      Hi,

       

      We have ported 43455 WICED SDK to NXP FRDM-K64 platform taking NXP's port for IMXRT1020 as a reference. Using LWIP as TCP/IP stack and running Amazon FreeRTOS.

       

      Our use case is as follows:

      - Device configures it self as an open AP on channel 1.

      - Device starts a DHCP server.

      - An Android or IOS mobile connects with the device AP.

      - Data exchange takes place

      - Device turns off the AP mode and moves to Station mode.

       

      We are observing the following issue:

      - After device is configured as open AP on channel 1, mobile tries to join the network. Network join is successful and mobile gets IP address from the Device.

      - Mobile after a few seconds, drops the connection by itself and then reconnects with the AP. This loop goes on for ever.

      - This issue is not reproduced on all mobile variants, Older phones (moto g series, Nokia 6.1 plus etc) seem to be having this issue but not phones like Samsung M31s or VIVO/Oppo/RealMe.

      - On the mobile phones that do have this issue we tried forgetting all the known APs so that the Mobile does not disconnect because of availability of better network, but that did not fix the issue.

      - The issue is not produced when working on Linux or windows system.

       

      Is there any possible missing configuration on 43455 side or on Network stack side that might be causing this issue?