3 Replies Latest reply on Sep 16, 2020 2:29 AM by JayakrishnaT_76

    Debug Configuration in SDK

    EsPo_3827446

      Hi,

       

      I want to debug the program.  

      Run->Debug Configuration

      Error with command: gdb --version

      Cannot run program "gdb": CreateProcess error=2, The system cannot find the file specified

       

      Thanks

      Esakki

        • 1. Re: Debug Configuration in SDK
          JayakrishnaT_76

          Hello,

           

          Please let me know the following details to understand the problem better:

          1. Which firmware are you trying to debug? Is it an SDK example or your own custom project?

          2. Are you making use of a custom board using FX3 or the Superspeed Explorer Kit or any other Reference Design Kits?

          3. Please let me know if you are trying to debug with OpenOCD or using Zegger J-Link.

          4. Did you go through the section 3 of EzUsbSuite_UG.pdf that comes along with FX3 SDK which describes in detail about JTAG debugging of FX3 projects? The document can be found in the following location:

           

          C:\Program Files (x86)\Cypress\EZ-USB FX3 SDK\1.3\doc\firmware

           

          Note: The path mentioned above depends on the installation directory of FX3 SDK.

           

          Best Regards,

          Jayakrishna

          • 2. Re: Debug Configuration in SDK
            EsPo_3827446

            Hi Jayakrishna,

             

            1. FX3 Superspeed Explorer Kit, both  example firmware and own custom project. Initially start with example SDK firmware -bulkloopauto.

            2. FX3 Superspeed Explorer Kit.

            3.  I followed EzUsbSuite_UG.pdf, I tried to debug with OpenOCD and Segger J-Link.

            4. Yes, I went through the section 3 of EzUsbSuite_UG.pdf, upto step 7, I didn't get popup window, I got bellow error.

             

            e1.JPG

             

             

            Thanks & Regards,

            Esakki

            • 3. Re: Debug Configuration in SDK
              JayakrishnaT_76

              Hello,

               

              Please follow the suggestion mentioned in response 5 of the following thread and let me know if it helps:

              Denebola CX3 board with JTAG Segger J-Link

               

              Best Regards,

              Jayakrishna