4 Replies Latest reply on Sep 15, 2020 12:34 AM by DheerajK_81

    PSoC Creator 4.3 autocomplete not working

    AlMa_1553431

      Hi,

       

      I've just installed PSoC Creator 4.3 and autocomplete doesn't seem to be working - here is my Environment & Installed CyInstaller Products;

       

      Environment:

      PSoC Creator  4.3 (4.3.0.1445)

      Culture: English (United States)

      OS Version: Microsoft Windows NT 10.0.19041.0

      CLR Version: 4.0.30319.42000

       

      Installed CyInstaller Products:

      CY8CKIT-042 PSoC 4 Pioneer Kit 1.0 Rev.*E

      CY8CKIT-042-BLE-A Kit 1.0 Rev.*B

      CY8CKIT-062-BLE PSoC 6 BLE Pioneer Kit 1.0 Rev.*E

      CySmart 1.3

      Peripheral Driver Library 2.1.0

      Peripheral Driver Library 3.0.1

      Peripheral Driver Library 3.1.1

      Peripheral Driver Library 3.1.2

      PSoC Programmer 3.28.7

      PSoC Creator 4.0

      PSoC Creator 4.3

      PSoC Designer 5.4 SP1

       

      I've tried with PSoC Creator 4.0 - and that seems to be working ok.

       

      Thanks,

      Alex

        • 1. Re: PSoC Creator 4.3 autocomplete not working
          DheerajK_81

          Hello Alex,

           

          The autocomplete should work once the project is built. Clean and build to see if it works after that.

           

          It so happens that sometimes the file is part of the project folder but not actually added to the project. Due to this, the project builds but it doesn't get referenced properly. Check if there is any file like that.

           

          Since there is no project attached, I'm not sure which function is not being recognized by the autocomplete. Is this some function in the PDL or a library dependency that you have added, please provide more information.

           

          Regards,

          Dheeraj

          • 2. Re: PSoC Creator 4.3 autocomplete not working
            AlMa_1553431

            Hi Dheeraj,

             

            Thanks for your reply. I've tried clean and build but still autocomplete doesn't seem to be working.

             

            I've got fresh install of PSoC Creator 4.3 install, and it's just a simple project that I'm trying to follow from the PSoC 6 101 youtube series; PSoC 6 101: Lesson 1-3 Hello World - YouTube

             

            I don't have any external files - this is a simple PWM / Led and Clock - Hello World 101 example... and after build I was expecting PWM_Start() function to autocomplete but doesn't seem to work for some reason. I've also have PSoC Creator 4.0, and that doesn't have this issue.

             

            I've attached the project attached for info as well.

             

            I've checked Tools/Options/Text Editor/Inline Diagnostics.. and autocomplete is enabled there.

             

             

            Thanks,

            Alex

            • 3. Re: PSoC Creator 4.3 autocomplete not working
              LePo_1062026

              Alex,

               

              I downloaded your project.  Auto-complete was working for me.  I don't know what to say ..

               

              Len

              • 4. Re: PSoC Creator 4.3 autocomplete not working
                DheerajK_81

                Hello Alex,

                 

                Please find the screenshot of the options I have for the Autocomplete feature:

                autocomplete.png

                 

                Please check if you have the same settings. In PSoC Creator, after you type part of the function name, press CTRL+SPACE. This is used to toggle between macros, non-macros and all filters. Check if you are able to see the function names when you are using the ALL or NON MACROS filter.

                filter.png

                 

                Regards,
                Dheeraj