8 Replies Latest reply on Sep 11, 2020 10:34 PM by ViCh_2676191

    Bootloader_BLE_Upgradable_Stack_App0 not building on psoc creator 4.3 (works in 4.2)??

    ViCh_2676191

      Hi,

       

      I have a PSoC6 dev kit and want to do upgradable stack OTA firmware upgrade through BLE. I have done this in psoc creator 4.2 but when I updated to 4.3, the example Bootloader_BLE_Upgradable_Stack_App0 project is not compiling. Particularly, it is removing/replacing certain files which has been modified for the upgradable stack application. In PSoC creator 4.2, it asks whether we want to replace or leave it as is and if we click on 'cancel' it works fine.

      psoc_issue_1.PNG

       

      I get the following errors when I try to go ahead with those files removed

       

      psoc_issue_2.PNG

       

      Is there a fix for this in psoc creator 4.3?

       

      I also saw that people are using Modus Toolbox instead. I like the PSoC creator. Should we be shifting to develop with that i9n the future?

       

      Thanks and Regards,

      Vimal