3 Replies Latest reply on Aug 19, 2020 1:14 AM by MoTa_728816

    All Cap Sense pins work but one ... Why?

    ScCl_3419596

      Using capsense on a new project but not matter what we have tried we can not get it to run on Button 1 P0(6) it is attached to.  Hoping to get some help as to why it does not work.

      Below is Current:

      Circuit.png

      Below is PCB Layout:

      PCB Layout.png

      the layout has a shield grid but it is not shown.  Note Button 0 works fine and also the proximity, we just get crickets from Button 1.

      I will also attach project.

        • 1. Re: All Cap Sense pins work but one ... Why?
          XiaoweiZ_71

          Please check the return value of CapSense_Start(), if return is 06, maybe the issue is caused by idac auto calibration failure.  Then you can try to downgrade CapSense component version from current v7_0 to v6_0 (Creator-->Project-->Update Components) , see if this can make buttons works. v7_0 used a new idac auto calibration algorithm which may cause calibrate failure on 3rd generation CSD block when sensor cp is low (<10pF).

           

          If downgrade CapSense component version still cannot fix the issue, you may check if P0[6] is shorted to Power or Ground.

          • 2. Re: All Cap Sense pins work but one ... Why?
            ScCl_3419596

            i tied downgrading the components but there still seems to be nothing happening with that sensor i have tried only operating that one sensor i have checked for shorts and open circuits ive check continuity and all that seems to checkout. im unsure what else could be going on. ill you plase help me debug this?

            • 3. Re: All Cap Sense pins work but one ... Why?
              MoTa_728816

              Hi,

               

              I'm just curious but you are using 2 buttons for 2 elements

              001-original.JPG

               

              I wonder if you merged them in to 1 button with 2 elements,  will it make any difference?

              002-merged.JPG

               

              moto