1 Reply Latest reply on Aug 14, 2020 5:05 AM by ChunleiL_51

    program does not run when entered into debugging mode

    daba_4649501

      greetings,

      AnjanaM_61SaEa_4705941broadcomwiced-adminMichaelF_56

      i am using CYBT-413055-02 custom module and i am using modus tool box 2.1 and sdk version <version>2.6.0.7989</version>.

      i can able to enter into debugging mode using SEGGER JLINK plus and configured SWD pins clock and Data pins.

      but when i run the program, the program is not running for example if i run hello sensor code..bluetooth does not advertise.

       

      when i pause the debugger , it goes directly to BUSY_WAIT_TILL_MANUAL_CONTINUE_IF_DEBUG_ENABLED(); to this macro and every time i pause the program, it does not come out of it.

       

      i made the spar_debug_variable=1 to non zero but still its not running.

       

      but when i tried command line debugging it works when i do the following steps,

       

      1. started the jlinkgdb server in the desktop and waiting for GBD connection.

      2. then started C:\Users\danny\ModusToolbox\tools_2.1\gcc-7.2.1\bin\arm-none-eabi-gdb.exe and ran the arm-none-eabi-gdb.exe file.

      3. typed commands like

       

      target remote localhost:2331

      symbol-file (the ELF PATH IN MY COMPUTER)

       

      monitor halt

      set var spar_debug_continue=1

      s

      }

      l

       

      continue

      4. if i followed the above steps , i can able to run the program once..cant reset or put breakpoints.

       

      please i need help with debug in modus tool box.

       

      thanks and regards,

      danny.