3 Replies Latest reply on Aug 3, 2017 2:58 AM by grsr

    GDB issues trying to Debug with Windows

    builty

      I'm trying to run the debugger from Eclipse on a board, running SDK 3.3.1 under Windows 7 64 bit.

      After the build this appears:

       

      warning: File "F:\projects\WICED\SDK\WICED-SDK-3.3.1\WICED-SDK\.gdbinit" auto-loading has been declined by your `auto-load safe-path' set to "$debugdir:$datadir/auto-load".

      To enable execution of this file add  add-auto-load-safe-path F:\projects\WICED\SDK\WICED-SDK-3.3.1\WICED-SDK\.gdbinit

      line to your configuration file "$HOME/.gdbinit".

      To completely disable this security protection add   set auto-load safe-path /  line to your configuration file "$HOME/.gdbinit".

      For more information about this security protection see the "Auto-loading safe path" section in the GDB manual.  E.g., run from the shell:  info "(gdb)Auto-loading safe path"

      .gdbinit_attach:1: Error in sourced command file:

      localhost:3333: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.

       

       

      From here I have to manually kill gdb to recover.

      I've searched a lot and tried to set the auto-load safe-path from a command line gdb session, but that doesn't apply to any other session.

      Download works fine, and OpenOCD seems all happy.

       

      Any advice would be greatly appreciated.

        • 1. Re: GDB issues trying to Debug with Windows
          builty

          Isn't anyone using the debugger on Windows?

          Very painful and slow having to do all debug via printfs.

           

          WICED would be a much better platform if it supported decent industry standard dev tools, like Keil MDK-ARM.

          Linux's trivial market share shouldn't compromise the experience of the vast majority.

          • 2. Re: GDB issues trying to Debug with Windows
            bachu.venkatesh_2300721

            Did you get an answer for this. I see the same issue. I followed all the other post https://community.cypress.com/thread/1715?q=gdb%20on%20windows  etc but nothing helped.

             

            Here is the error when i select debug target

             

            Creating Filesystem Done

            GNU gdb (GDB) 7.7

            Copyright (C) 2014 Free Software Foundation, Inc.

            License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>

            This is free software: you are free to change and redistribute it.

            There is NO WARRANTY, to the extent permitted by law.  Type "show copying"

            and "show warranty" for details.

            This GDB was configured as "--host=i686-pc-mingw32 --target=arm-none-eabi".

            Type "show configuration" for configuration details.

            For bug reporting instructions, please see:

            <http://www.gnu.org/software/gdb/bugs/>.

            Find the GDB manual and other documentation resources online at:

            <http://www.gnu.org/software/gdb/documentation/>.

            For help, type "help".

            Type "apropos word" to search for commands related to "word"...

            Reading symbols from build/puma.puma_wifi_sta_app-BCM943907AEVAL1F/binary/puma.puma_wifi_sta_app-BCM943907AEVAL1F.elf...done.

            warning: File "C:\workspace\puma-cypress\WICED\WICED-Studio-4.1\43xxx_Wi-Fi\.gdbinit" auto-loading has been declined by your `auto-load safe-path' set to "$debugdir:$datadir/auto-load".

            To enable execution of this file add

            add-auto-load-safe-path C:\workspace\puma-cypress\WICED\WICED-Studio-4.1\43xxx_Wi-Fi\.gdbinit

            line to your configuration file "$HOME/.gdbinit".

            To completely disable this security protection add

            set auto-load safe-path /

            line to your configuration file "$HOME/.gdbinit".

            For more information about this security protection see the

            "Auto-loading safe path" section in the GDB manual.  E.g., run from the shell:

            info "(gdb)Auto-loading safe path"

            .gdbinit_attach:1: Error in sourced command file:

            (gdb) quit

            Remote communication error.  Target disconnected.: No error.

            Build complete

            Making .gdbinit

            • 3. Re: GDB issues trying to Debug with Windows
              grsr

              Please refer to the WICED Quick Start Guide in the WICED docs section for instructions on using the debugger. The debug build statement needs to be written correctly to avoid such errors.

              1 of 2 people found this helpful