3 Replies Latest reply on Jul 9, 2020 6:40 PM by yasa_4608926

    v5.4.18-backports issues


      Hi all,


        Our device we are working with v4.14.34-backports. Now recently I am trying to upgrade the driver using v5.4.18-backports drop. I get the following error.


      Loading BRCM FMAC Driver...Loading BCM43555 FMAC WLAN Firmware in Production Mode 07/06/20 10:46:43.851313 kern.inf kernel: Loading modules backported from e

      07/06/20 10:46:43.851405 kern.inf kernel: Backport generated by backports.git v5.5.11-1-0-gabe05f0

      07/06/20 10:46:43.861284 kern.not kernel: cfg80211: Loading compiled-in X.509 certificates for regulatory database

      07/06/20 10:46:43.871289 kern.not kernel: cfg80211: Loaded X.509 cert 'sforshee: 00b28ddf47aef9cea7'

      Wland restarted. Pls wait...

      07/06/20 10:46:43.931298 kern.inf kernel: brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43455-sdio for chip BCM4345/6

      07/06/20 10:46:43.931400 kern.inf kernel: usbcore: registered new interface driver brcmfmac

      07/06/20 10:46:43.931430 kern.war kernel: brcmfmac mmc1:0001:1: Direct firmware load for brcm/brcmfmac43455-sdio.fsl,imx7d-sdb.txt failed with error -2

      07/06/20 10:46:43.931468 kern.war kernel: brcmfmac mmc1:0001:1: Falling back to user helper


      any help

        • 1. Re: v5.4.18-backports issues



          For nvram files are board-specific, first request will be tried using a board-specific path.

          If it fails, it will be tried without a board-specific path.


          see brcmf_fw_request_firmware() in drivers/net/wireless/broadcom/brcm80211/brcmfmac/firmware.c.

          There is no problem if it is only an error message for a board-specific path.


          Are the following files in /lib/firmware/brcm directory?

          brcmfmac43455-sdio.bin, brcmfmac43455-sdio.txt, brcmfmac43455-sdio.clm_blob


          Best regards,


          • 2. Re: v5.4.18-backports issues

            Hi Yasa Thanks for your reply. Yes we have brcmfmac43455-sdio.bin, brcmfmac43455-sdio.txt, brcmfmac43455-sdio.clm_blob in /lib/firmware/brcm folder

            • 3. Re: v5.4.18-backports issues



              Does the kernel module still fail to load?

              If it fails, load the kernel module(brcmfmac.ko) with debug=0x0004(or 0x0006 etc.) parameter and check the output of dmesg.

              You may need to enable CPTCFG_BRCMDBG=y and/or CPTCFG_BRCM_TRACING=y in fmac building configuration.

              See FMAC Debugging .


              Best regards,