2 Replies Latest reply on Jul 3, 2020 10:11 AM by RyWi_4724536

    PSoC6 Basic Device Firmware Update Project Is Trying to Use Old PDL Version

    RyWi_4724536

      I am trying the example PSoC6 MCU Basic Device Firmware Update application note CE213903.

      I downloaded two projects: PSoC6DfuBasicApp0Uart01, and PSoC6DfuBasicApp1.

       

      The Uart01 project builds fine, but the App1 project won't build and gives the error:

      C:\Users\Ryan's Laptop\Documents\PSoC Creator\DFU_Kit\PSoC6DfuBasicApp101.cydsn>"C:\Program Files (x86)\Cypress\PDL\3.0.1""\tools\win\elf\cymcuelftool.exe" -P .\CortexM4\ARM_GCC_541\Debug\PSoC6DfuBasicApp101.elf --output .\CortexM4\ARM_GCC_541\Debug\PSoC6DfuBasicApp101.cyacd2

      The system cannot find the path specified.

       

      It looks like the problem is it is trying to use C:\Program Files (x86)\Cypress\PDL\3.0.1, BUT I have only have PDL versions 3.1.1 and 3.1.2 not 3.0.1

       

      I checked in Tools->Options Project Management the PDL version is set to 3.1.2, and under Project Build Settings under Peripheral Driver Library it is set to default(3.1.2).

       

      Any idea why creator is trying to use the old PDL version? And how can I change it to use the most recent one?

       

      Thanks!