1 Reply Latest reply on Jun 25, 2020 10:27 PM by GauravS_31

    Cypress WLAN Setting method to achieve max T-put at 2.4GHz band (wpa_cli command or hostapd.conf option)

    DoKi_4636536

      Hi, all.

       

      I'm testing the Murata's BT/WLAN combo chip.
      The dhd driver I apply is provied by Cypress, and supplicant and hostapd use the one provided by Linux.
      I'm setting it up in two ways.
      The first method is provided by Murata, and the second is provided by Cypress.

       

      *************************************************************************************
      1. Murata's guide
      Doc : quick_start_guide_linux(6.0).pdf

       

      <AP>
      killall wpa_supplicant
      hostapd -B /etc/hostapd.conf


      * IP is dynamically allocated through dhcp-server.
      * udhcpd is not used because IP allocation uses dhcp-server.

       

      <STA>
      ./wl join TEST_AP (: ssid name)
      ./wl assoc
      *************************************************************************************

      *************************************************************************************
      2. Cypress's guide
      Doc : sdio_bringup_for_rsdb_concurrency_scenarios.pdf

      <AP>
      killall wpa_supplicant
      wpa_supplicant -iwlan0 -Dnl80211 -c/etc/wpa_supplicant.conf -dd -B
      wpa_cli -iwlan0 -p /var/run/wpa_supplicant

       

      wpa_cli -iwlan0 remove_net all

      wpa_cli -iwlan0 add_net


      wpa_cli -iwlan0 set_net 0 ssid '"AP_2G"' (or AP_5G)
      wpa_cli -iwlan0 set_net 0 key_mgmt NONE
      wpa_cli -iwlan0 set_net 0 frequency 2437 (or 5180)
      wpa_cli -iwlan0 set_net 0 mode 2


      wpa_cli -iwlan0 select_net 0

       

      <STA>
      killall wpa_supplicant
      wpa_supplicant -iwlan0 -Dnl80211 -c/etc/wpa_supplicant.conf -dd -B
      wpa_cli -iwlan0 -p /var/run/wpa_supplicant

       

      wpa_cli -iwlan0 disconnect 

      wpa_cli -iwlan0 list_network 
      wpa_cli -iwlan0 remove_net 0 

      wpa_cli -iwlan0 add_net 


      wpa_cli -iwlan0 set_net 0 ssid '"AP_2G"' (or AP_5G) 
      wpa_cli -iwlan0 set_net 0 key_mgmt NONE 
      wpa_cli -iwlan0 enable_network 0 


      wpa_cli -iwlan0 select_network 0 
      *************************************************************************************

       

      If I set it to 5GHz band, the setting result is 802.11ac with BW 80MHz and NSS = 2 (Max T-put 867Mbps).
      If I set it to 2.4GHz band, the setting result is 802.11n with BW 20MHz and NSS = 1 (Max T-put 72Mbps).

       

      For 5GHz band, there is no problem as it is the maximum T-put setting.
      The 2.4GHz band requires additional setting for max T-put (40MHz BW and NSS=2, 300Mbps??) but I don't know how.

       

      I looked for setting in wpa_cli and chaning the hostapd.conf option, but it did not work.
      (i.e wpa_cli -iwlan0 set_net 0 frequency 2437/40 @ for manual setting ,
      option hw_mode, channel, 80211n, 80211ac option @ hostapd.conf)


      Please can someone tell me how to set up to achieve max T-put at 2.4GHz band?

      Best regards.

       

      DongHwi