2 Replies Latest reply on Oct 7, 2015 9:28 PM by jone_yi_1844281

    SDK 3.1.2 downloading problem

    user_272072780

      Hi,

       

      My purpose is downloading my new SDK 3.1.2 codes (sflash.bin, waf_bootloader-NoOS-NoNS-BCM9WCDUSI09-SDIO.elf, Arwen_v4_01_03-BCM9WCDUSI09, DCT.elf) to the board which has my old SDK 2.4.1 codes.

       

      I have 2 ways to do that.

       

      1) using WICED IDE: after using Arwen_v4_01_03-BCM9WCDUSI09 JTAG=jlink download download_apps run, I see below messages. Unfortunately I cannot succeed downloading.

       

      Downloading Bootloader ...

      Building apps lookup table

      Download complete

       

       

      Downloading DCT ...

      "**** OpenOCD failed - ensure you have installed the driver from the drivers directory, and that the debugger is not running **** In Linux this may be due to USB access permissions. In a virtual machine it may be due to USB passthrough settings. Check in the task list that another OpenOCD process is not running. Check that you have the correct target and JTAG device plugged in. ****"

      Downloading Application ...

      "**** OpenOCD failed - ensure you have installed the driver from the drivers directory, and that the debugger is not running **** In Linux this may be due to USB access permissions. In a virtual machine it may be due to USB passthrough settings. Check in the task list that another OpenOCD process is not running. Check that you have the correct target and JTAG device plugged in. ****"

      Downloading APP0 (build/Arwen_v4_01_03-BCM9WCDUSI09/binary/Arwen_v4_01_03-BCM9WCDUSI09.stripped.elf) at sector 1...

      Downloading apps lookup table at 0x0000...

      Resetting target

      Target running

      Build complete

       

       

      17:19:57 Build Finished (took 1m:7s.797ms)

       

      2) Batch file method (please see attached file we are using openOCD) : Our batch file is working good for SDK 2.4.1 codes. Unfortunately, when I want to use this way to upgrade board to the SDK3.1.2 codes, at first trial I see download failed message. After that I try again and even if I see download complete message, application code does not work. At the end my 3rd trial I succeed and and new SDK 3.1.2 application code works properly.

       

      After downloading process succeeded, I try again WICED IDE, It works properly.

       

      Waiting for your comments...

       

      Best regards