1 Reply Latest reply on Jul 6, 2020 8:33 AM by VinayakS_26

    When setting to AP mode, inquire ping between AP and station

    DoKi_4636536

      Hi, all.

       

      I'm working on a throughput performance test with a murata module using a cypress BT/WLAN combo chip.
      All other basic tests have been completed and throughtput performance test is currently being measured as the final step.
      It uses the dhd driver provided by cypress, and wpa_supplicant and hostapd are provided by linux.

      It is measuring the throughput performance between 2-stations connected to AP.

       

      What is curious is that if our board is used as AP mode (wifi hotspot), communication between AP and STA does not work.
      In this case, communication between stations are possible.

      (This is not p2p. Therefore, communication between stations is performed via AP)


      The result is the same when both the AP and the stations have a static IP as well as when the AP allocates the station's IP dynamically.
      Of course, if the commercial smartphone is set as an AP (wifi hotspot) and tested, communication between AP and stations are possible.

       

      Do you need to change any additional settings in hostapd.conf or wpa_supplicant.conf?
      If not, what additional work is required?

       

      Our development environment is below:
      - freescale i.mx8qxp AP
      - yocto distritution based on linux 4.14.98
      - SDIO interface between AP and WLAN / BT combo module

       

      Best regards.

       

      DongHwi