5 Replies Latest reply on Jun 25, 2020 6:50 PM by MinQ_41

    S6E2CC Flash erased

    TsSh_4608526

      Hi everyone:

       

      I am using S6E2CC as my development board, but I need to use Segger J-link as the IDE.

       

      I had already erased my flash by using 'FLASH USB DIRECT Programmer', however, the system still not boot up as a J-link.

      I think the problem is my HEX file in 'SK-FM4-176L-S6E2CCA_CDv1.1' is 'SK-176-s6e2ccTestCode-V12.srec'

      But on this website: https://www.segger.com/products/debug-probes/j-link/models/other-j-links/j-link-ob-spansion/

      the HEX file title is "J-link-OB-XXXXX"

      So if I want to boot up my board as a J-link device, where can I get this Hex file?

       

       

       

      another problem is I try to erase and download the flash again, my setup is:

      J1: close,

      J2: open,

      J3: 2-3,

      J4: 1-2

       

      my PC shows added COM port(USBVCOM)(COM14)

      but when I use 'full operation', it shows 'Error!! No.006 Unable to open COM port'

      Is it because I had already booted up the board? or my setup is not correct?

      Thanks for your help!

       

      Regards,

      Shen

        • 1. Re: S6E2CC Flash erased
          MinQ_41

          Hello,

           

          Do you mean you need debug the kit board with J-Link?

          The default mode of SK-FM4-176L-S6E2CCA is CMSIS-DAP.

          if use J-Link, please connect SWDIO pin with J-Link 7pin, SWCLK with J-Link 9pin, then connect VCC and GND respectively.

           

          for your other question, please ensure all jumpers like as below

           J1 open

           J2 open

           J3 2-3

           J4 1-2

           

          Please try it again.

          • 2. Re: S6E2CC Flash erased
            TsSh_4608526

            Hi MinQ:

             

            No, I originally used Keil as my IDE, but my professor want me to switch Keil to Segger Embeded Studio for ARM. So Actually I don't have any device of J-link, but I'm not sure if I can use S6E2CC board directly on Segger IDE just like using Keil.

             

            My situation is I boot up the board, but in Segger IDE, it doesn't find the emulator. And also I can not go back to Keil because the flash is erased.

             

            Is it possible to use S6E2CC on Segger without J-link device? or how can I reset my flash and program on Keil?

            Thank a lot!!!

            • 3. Re: S6E2CC Flash erased
              MinQ_41

              Hello,

               

              yes, it can use this kit board without J-Link, but firstly please configure it to use CMSIS-DAP mode in IAR or KEIL

               

              In IAR: Project -> options ->  Debugger -> setup -> Driver, select CMSIS DAP in driver list.

              and then CMSIS DAP -> interface -> select SWD.

               

              In KEIL:  options -> Debug ->  select CMSIS- DAP Debugger

               

              • 4. Re: S6E2CC Flash erased
                TsSh_4608526

                Hi MinQ,

                 

                Thanks for your response!

                Ok, I try to configure it to use CMSIS-DAP mode, but it doesn't work. I'm not pretty sure I'm doing in the right way.

                I use Keil to configure it.

                My sequence is: Project -> Options for Target -> Debug -> use: CMSIS-DAP Debugger

                option.PNG

                but In Segger IDE

                se.PNG

                It's still not working.

                the jumper of S6E2CC kit is:

                > J1 open

                > J2 open

                > J3 2-3

                > J4 1-2

                 

                Thanks for your kindly help!!!

                • 5. Re: S6E2CC Flash erased
                  MinQ_41

                  Hello,

                   

                  if you use CMSIS-DAP mode, J-Link information should not appear.

                  This means that your configuration is not correct.