8 Replies Latest reply on Jul 3, 2020 6:16 AM by DheerajP_41

    CYBT-333032-02 custom board flash question

    BeTa_4607436

      Hi all,

       

      I have a custom module based on CYBT-333032-02, and it has only the UART pins out , and it is used directly on another custom board that supports those pins, and the board is running Linux to attach the detected UART module which is CYBT-333032-02.

       

      So the main question is how to flash that module with WICED ? and what equipment do I need for that ?

       

      Thanks , Talel

        • 1. Re: CYBT-333032-02 custom board flash question
          DheerajP_41

          Hi,

           

          You can generate the .hex or .hcd using WICED, and try using chipload tool.

          How to use Chipload: Programming using ChipLoad.exe

           

          Please find the attached file.

           

          Thanks,

          -Dheeraj

          1 of 1 people found this helpful
          • 2. Re: CYBT-333032-02 custom board flash question
            BeTa_4607436

            Thanks for the reply,

            But I want to ask you question, our custom board contains only the chip, and no flash is there.

            Because one of my teammates told me that cypress evalboard contains a flash memory to load the binary in, that is why my custom board cannot be flashed !

            Is this is true ?

            • 3. Re: CYBT-333032-02 custom board flash question
              BeTa_4607436

              Hello,

              THIS IS AN URGENT REQUEST

              Here is a detailed description about our custom cypress module.

              The module is : CYBT-333032-02 and here is the datasheet : https://www.cypress.com/file/464611/download

              Our module is a Bee connected one, and here are photos:

              IMG20200626163247.jpg

               

              IMG20200626163255.jpg

              IMG20200626163301.jpg

              We need to flash the module with HCI driver in order to use it in a board with Linux image and attach it with hciattach.

              In order to do that, I've tested flashing it with WICED Studio after connecting the module with an FTDI cable to the computer.

              I've tested that the module is powered correctly , but WICED cannot detect the device after selecting the hci_uart demo project.

              I also tested running Chipload utility but it didn't provide me with any output.

              Please Help me to solve the issue and how to flash the module.

              Thanks.

              • 4. Re: CYBT-333032-02 custom board flash question
                DheerajP_41

                Hi,

                 

                Yes, The CYBT-3330xx-02 includes 512 KB of onboard serial flash memory and is designed for standalone operation.

                 

                Did you recover (put the device into download mode) the device before download?

                 

                "When the device is initially powered on the boot code will attempt to identify the hardware interface to be used for HCI

                communication. For UART, the device behavior depends on the state of CTS when RST_N is de-asserted. If CTS is LOW

                at this time, the device enters the autobaud state (download mode). If CTS is HIGH after reset, the device will check NVRAM

                and apply any stored configuration, typically ending in a mode ready to accept all HCI commands at a default baud rate. If

                no configuration is available, the device will also enter autobaud mode."

                 

                You can refer WICED-HCI-Control-Protocol.pdf  to understand more details. Please read through "2.2 Preparing for HCI Commands" section.

                 

                What is the chipload tool log shows while trying to download? Are you getting any error log?

                 

                Thanks,

                -Dheeraj

                1 of 1 people found this helpful
                • 5. Re: CYBT-333032-02 custom board flash question
                  BeTa_4607436

                  Did you recover (put the device into download mode) the device before download?

                  Yes I did same steps for recover.

                  I tested the same process with evalboard successfully.*

                  What is the chipload tool log shows while trying to download? Are you getting any error log?

                  No log , and no output got from chipload.

                   

                  I have tested our module by connecting it directly to the J26 UART pins of the EVALBOARD in order to separate the FTDI from the EVALBOARD's chip, and WICED is not able to detect our module.

                   

                  Detecting device...

                  ********* Detection Failure *************

                  When disabling the EVALBOARD's SW7 switch WICED also cannot detect the device, so my question , is our module ,by chance, does not implement the switch for serial flashing ?? If it is not, it that the source of the problem ?

                  • 6. Re: CYBT-333032-02 custom board flash question
                    DheerajP_41

                    Hi,

                     

                    Could you please compare the Module EVAL kit schematics with your custom module board schematic and check whether you are missing any connection or not? Please find the attachment.

                    I feel it is some kind of HW issue with the custom board.

                     

                    SW7 on the CYW920706WCDEVAL is to configure the serial flash (U2 external) and authentication IC connections.

                    CYBT-3330xx-02 is having 512-KB on-module serial flash memory.

                     

                    You can try sending HCI Commands (HCI_RESET) command to the module board via UART to check whether it is responding or not in normal operation. This can confirm that the connection and power are proper. One good and simple test will be as below.

                    1. Use the FTDI of the EVAL board to communicate to the custom module board as you mentioned.

                    2. Connect the USB of the EVAL board to your PC.

                    (The PC is connected to EVAL board vie USB and EVAL board is connected to custom module board via HCI UART).

                    3. Send HCI_RESET and check whether board responds or not.

                    (You can use cybluetool or any Serial emulation (Eg. Realterm) program to test this)

                     

                    Links: https://www.cypress.com/products/ble-bluetooth

                     

                    Thanks,

                    -Dheeraj

                    1 of 1 people found this helpful
                    • 7. Re: CYBT-333032-02 custom board flash question
                      BeTa_4607436

                      Hi,

                      thanks for the reply ,

                      The eval board and our custom module both respond to HCI commands with CyBlueTool.

                      But , our custom board respond only in RECOVERY mode.

                      And if I try to attach our module with hciattach in recovery mode , it can't be attached (timeout)

                      What should I do ?

                      • 8. Re: CYBT-333032-02 custom board flash question
                        DheerajP_41

                        Hi,

                         

                        With the same setup, please do the recovery and try to program the board using chipload tool.

                        At-least some error log it should produce. (Since HCI reset is working).

                         

                        If you are using WICED please share the "download.log" generated in the build folder.

                         

                        Please check: Programming using ChipLoad.exe

                         

                        Thanks,

                        -Dheeraj

                        1 of 1 people found this helpful