6 Replies Latest reply on Sep 28, 2017 4:10 AM by engin.875

    transmit testing - changing power level

    flex-norcross

      We followed this example from WICED-MFG202-R.pdf to generate a carrier wave using the mfg test app running on a BCM9433642WCD4 module:

       

      wl --serial 99 down

      wl --serial 99 country ALL

      wl --serial 99 band b

      wl --serial 99 mpc 0

      wl --serial 99 up

      wl --serial 99 out

      wl --serial 99 fqacurcy 6

       

       

      We see the spike with the spectrum analyzer. Then we attempted to change the power level via: txpwr1 -d 15 and also tried using milliwatts units. We cannot get the power level to change. The test app claims the power level has changed as reflected by the return value of the txpwr command, but the output on the spectrum analyzer does not change.


      We also performed the modulated test from the same document:

       

      wl --serial 99 down

      wl --serial 99 country ALL

      wl --serial 99 band b

      wl --serial 99 chanspec -c 1 -b 2 -w 20 -s 0

      wl --serial 99 mpc 0

      wl --serial 99 ampdu 1

      wl --serial 99 bi 65000

      wl --serial 99 frameburst 1

      wl --serial 99 rateset 11b

      wl --serial 99 up

      wl --serial 99 txant 0

      wl --serial 99 antdiv 0

      wl --serial 99 nrate -r 11

      wl --serial 99 phy_watchdog 0

      wl --serial 99 disassoc

      wl --serial 99 txpwr1 -1

      sleep 3

      wl --serial 99 pkteng_start 00:90:4c:aa:bb:cc tx 40 1000 0

       

      We see that the spectrum has broadened due to the modulation but the txpwr1 again has no effect in changing the actual power level.

       

       

      (1) What is the correct way to change the power level for carrier wave and modulated transmit tests using the mfg test app?

       

      (2) Is there a programmatic way to do this in our app via the WICED API?

        • 1. Re: transmit testing - changing power level
          jone_yi_1844281

          Try change power level before bring up!

           

          • 2. Re: transmit testing - changing power level
            mindaugas

            jone_yi_1844281

            I'm am preparing device for FCC certification and also have the same problem. I also use txpwr1 command to change power, but spectrum analyzer doesn't show any changes. Changing power setting before "up" didn't help. Did you solve this problem?

            • 3. Re: transmit testing - changing power level
              jone_yi_1844281

              Do you check the txpwr1 command ?

              See how it used for ?

              Check your wl with no command!

              1 of 1 people found this helpful
              • 4. Re: transmit testing - changing power level
                mindaugas

                1. Do you check the txpwr1 command ?

                Yes. I checked txpwr1 command. Every time I set a new value using this command I get a confirmation from module that it was changed.

                 

                2. See how it used for ?

                Yes. I was referencing document 80211-TI204-R.pdf.

                 

                3. Check your wl with no command!

                Please explain what is the use of this?

                 

                txpwr1 command was used in the same manner as in flex-norcross massage. I ran the script that contained command sequence that is presented below. I've been able to see broadbanded spectrum in selected channel but no TX power changes.

                 

                echo Transmit 802.11b : Start

                 

                set comport=5

                 

                set target=43362A2

                rem set target=4390A1

                rem set target=43341B0

                 

                ..\wl%target% --serial %comport% down

                ..\wl%target% --serial %comport% country ALL

                ..\wl%target% --serial %comport% band b

                ..\wl%target% --serial %comport% chanspec -c 1 -b 2 -w 20 -s 0

                ..\wl%target% --serial %comport% mpc 0

                ..\wl%target% --serial %comport% ampdu 1

                ..\wl%target% --serial %comport% bi 65000

                ..\wl%target% --serial %comport% frameburst 1

                ..\wl%target% --serial %comport% rateset 11b

                ..\wl%target% --serial %comport% up

                ..\wl%target% --serial %comport% txant 0

                ..\wl%target% --serial %comport% antdiv 0

                ..\wl%target% --serial %comport% nrate -r 11

                ..\wl%target% --serial %comport% phy_watchdog 0

                ..\wl%target% --serial %comport% disassoc

                ..\wl%target% --serial %comport% txpwr1 -d 10 -o

                @echo sleep 3 seconds

                @ping -n 3 127.0.0.1 > nul

                ..\wl%target% --serial %comport% pkteng_start 00:90:4c:aa:bb:cc tx 40 1000 0

                 

                I also tried to put txpwr1 command before up command, still no changes. Also no changes in TX power when generating carrier wave.

                 

                Can someone point to right direction how to change TX power properly.

                • 5. Re: transmit testing - changing power level
                  jone_yi_1844281

                  try bring down wifi , then change power, and bring up, to apply the new power level!

                   

                  wlxxxx --serial 99 down

                  wlxxxx --serial 99 txpwr1 -d 10

                  wlxxxx --serial 99 up

                  1 of 1 people found this helpful
                  • 6. Re: transmit testing - changing power level
                    engin.875

                    Hi,

                    do you know the solution of this problem. i have same problem now.