2 Replies Latest reply on Jun 17, 2020 10:02 PM by GaneshD_41

    PSoC requires 5v instead of 3.3v and model wrong in "Programming device 'PSoC 4200 BLE CY8C4247LQ*-BL483'" and only programs with 5v.

    MaSt_1539621

      CY8C4247LQ* should be CY8C4247LQI. The real problem is that it requires 5v to program and run and I think maybe it's because it's not properly recognizing the device.

       

       

      The device name is wrong and I think it might be causing other anomalous problems, such as only programming and running with 5v, instead of the 3.3v required by the chip.

       

      I tried updating the firmware of the MiniProg4 that I'm using to connect, but have not solved the problem.

       

      MiniProg4. CMSIS-DAP Version 2.0.0. Firmware Version 1.01.158. Hardware Id 05.

      If I try to program using PSoC Programmer at 3.3v I get:

      Program Finished at 9:38:56 AM                                                      |

                                                                                          | FAILED! EraseAll operation failed!

      Device set to CY8C4247LQI-BL483 at 9:38:56 AM                                      | 131072  FLASH bytes

      Device Family set to CY8C4xxx-BLE at 9:38:56 AM                                    |

                                                                                          | Automatically Detected Device: CY8C4247LQI-BL483

                                                                                          | Silicon: 0E34, Family: 9E, Major/Minor Rev: AI

      The device name looks correct there, but when I try to program with PSoC Creator I get: