3 Replies Latest reply on Jul 21, 2020 7:01 PM by KaNa_3391246

    BCM4355 WIFI and BLE issues



        I have an BCM4355 chip interfaced to SM32MP157 processor,both the drivers for WIFI/BLE are loading.But while running any operation on them I am facing issues.


      WIFI Issues:

      1.Both AP and STA mode are not running simultaneously at a time only AP mode is running.

      2.If I run the wifi supplicant I was getting below errors


      [ 1860.606056] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready

      [ 1861.315129] mmci-pl18x 48004000.sdmmc: unaligned scatterlist: ofst:400 length:472

      [ 1861.321174] brcmfmac: brcmf_sdiod_sglist_rw: CMD53 sg block read failed -22

      [ 1861.328768] brcmfmac: brcmf_sdio_rxglom: glom read of 1024 bytes failed: -5

      [ 1861.335194] brcmfmac: brcmf_sdio_rxfail: abort command, terminate frame

      [ 1861.342199] brcmfmac: brcmf_sdio_readframes: brcmf_sdio_readframes: glom superframe w/o descriptor!

      [ 1861.350832] brcmfmac: brcmf_sdio_rxfail: terminate frame

      [ 1866.775418] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready

      [ 1867.931267] mmci-pl18x 48004000.sdmmc: unaligned scatterlist: ofst:818 length:116

      [ 1867.937425] brcmfmac: brcmf_sdiod_sglist_rw: CMD53 sg block write failed -22

      [ 1867.944356] brcmfmac: brcmf_sdio_txfail: sdio error, abort command and terminate frame



      BLE Issues:

      On boot up I am getting below prints w.r.t Bluetooth

      Bluetooth: hci0: command 0x0c03 tx timeout

      Bluetooth: hci0: BCM: Reset failed (-110)


      If I run the bluetoothctl tool I was returning below error



      Agent registered

      [bluetooth]# power on

      No default controller available


        Can anyone help me how to fix these errors for my module.Thanks in advance.