2 Replies Latest reply on May 28, 2020 2:15 PM by ChFo_4708886

    FX3 USB Serial Driver Fails to install under Windows 10 and Windows 7

    ChFo_4708886

      Hello,

       

      I have been trying to install the CYUSB3Kit-003 EZUSB FX3 USB Serial driver in order to create a COM (serial) port in Windows, but I have not had success installing the driver.

      After successfully installing the driver for FX3 via the SDK, I downloaded and installed the USBSerialSDKSetup.exe from https://www.cypress.com/documentation/software-and-drivers/usb-serial-software-development-kit  and attempted to install on a Windows 10 machine.

      I ran the setup and then located the driver file, cyUSB3.inf to manually install it via Windows Device Manager, and I received a message that my driver did not successfully install, error code 31.  I tried uninstalling and reinstalling it with no luck. I also tried the CypressSerial.inf driver. deviceNotWorkingProperly.pngdriverError.pngI tried the same process on a Windows 7 machine and I had the same issues (Please, see images below).  The USB serial device driver "installs" but will not work properly because Windows cannot load it. So it shows up in the Device Manager list with a warning next to its name.

       

      The FX3 SDK installed successfully, is there a working driver for the USB Serial function as well? The Cypress drivers don't load properly for Windows 10 or Windows 7.  There are also Cypress USB serial drivers that Windows includes under the Ports and LPT device, but they also do not load properly.

       

      Is there a method that I am missing here? I'd like to get this driver installed so that I can communicate with it via the serial port.

       

      Thanks