1 Reply Latest reply on May 28, 2020 7:00 PM by PY_21

    CY5677- Issues with operating dongle

    RaSe_4033676

      Hello.

       

      We are currently using CY5677 to communicate with our device using the CYBLE-224110-00.

       

      we have found that the use of the CY5677 in a production/manufacturing environment and even in some cases under lab tests, is not stable.

       

      Cysmart crashes often, the dongle suddenly disappears and only a power cycle can make it available for use again.

       

      Please answer the following questions:

      1. Is there a more reliable solution than the 5677 Dongle? a more robust and stable version?

      2. How do you treat the issue similar to this case CY5677 dongle "Not a valid CySmart dongle!" without using the power cycle solution.

      3. is there an industrial level product that can be used instead?

        • 1. Re: CY5677- Issues with operating dongle
          PY_21

          Hello,

           

          1. Could you please let me know which version of Cysmart you are using ? If you are using the old version, then please upgrade to the latest version v1.3.
          2. Update and program the BLE Dongle firmware. You can find the hex file from the following path.
          C:\Program Files (x86)\Cypress\CySmart\1.3\dongle\CY5677

           

          CY5677 CySmart BLE 4.2 USB Dongle is a robust and stable version featuring a Bluetooth 4.2-compliant PSoC 4 BLE, enabling you to test and debug Bluetooth Low Energy (BLE) systems.

           

          Please let me know if you are still facing any issues after updating.

           

          Thanks,
          P Yugandhar.