5 Replies Latest reply on Jun 1, 2020 11:31 AM by KeFo_4700586

    CYBT_413034_EVAL device not detected.

    KeFo_4700586

      I am having problems when programming the CYBT_413034_EVAL board from Wiced Studio 6.4.61

      I've created a make target for the platform, using the spp example in the apps directory:

      snip.bt.spp-CYBT_413034_EVAL download BT_DEVICE_ADDRESS=20200521FFEE

       

      This target builds with no errors, but it often fails to connect with the target. I must perform a board recovery (hold recovery switch while pressing and releasing reset switch). This allows me to load new code once, then I have to repeat the process for another download.

      I've tried with a number of different sample apps, always with the same loading result.

       

      I do get debug info logged to a putty console, with the following output:

       

      APP Start

      app_management_callback 21

      app_management_callback 0

      hci_control_write_eir 2666e0

       

      EIR :09 09 73 70 70 20 74 65 73 74 03 03 01 11 00

       

      spp_rfcomm_start_server: rfcomm_create Port: 0x0002

      app_management_callback 20

      app_management_callback 20

      app_timeout: 1

      app_timeout: 2

      app_timeout: 3

      app_timeout: 4

      app_timeout: 5

        • 1. Re: CYBT_413034_EVAL device not detected.
          XinghaoZ_26

          Please use the recover procedure if you can't detect the device.

          This may happen if the HCI UART configuration isn't the default setting. You may try the hello_sensor demo to see if still need the recover procedure.

          • 2. Re: CYBT_413034_EVAL device not detected.
            KeFo_4700586

            As I mentioned, I have to apply the recover procedure EACH time following a download of a demo to the CYBT_413034_EVAL-01 module, otherwise I get the connection error:

             

            No CYBT_413034_EVAL device detected.   

            1. Verify the CYBT_413034_EVAL board is connected _AND_ powered 

            2. Verify jumper J2 is populated 

            3. Verify SW4 switches(CTS, RTS, RXD, TXD) are in ON position

            4. Press the reset button on the CYBT_413034_EVAL board and retry  

             

            What are the HCI Default UART settings for this module and where can I find them in the SDK?

             

            I am using a CYBT_413034_EVAL-01 module for my tests. Do I need a CYBT_413034_EVAL-02 module to work with Wiced Studio?

             

            Could there be Library alignment problems with the Bluetooth stack (V4.6?) on ROM in the -01 device I have versus the -02 Bluetooth stack (V5.0) n the -02 device platform profile in Wiced Studio?

             

            Or perhaps a problem with the bootloader in the module? It appears that the module may simply lock up, perhaps in reset mode with no code running during the firmware loading process unless I apply the restore procedure.

            • 3. Re: CYBT_413034_EVAL device not detected.
              XinghaoZ_26

              It is normal if you have to program a device in the recover mode.

              You may take a look at the module programmer tool and the user guide: WICED Module Programmer User Guide – KBA225060

              • 4. Re: CYBT_413034_EVAL device not detected.
                KeFo_4700586

                I am still unable to run a Bluetooth example of any kind on the EVAL board. I now have a second CYBT-413034-EVAL-02 dev board from Digikey. I checked all the jumpers and the switch settings on the board and plugged it into the PC. two com ports were created (good). I could putty into the higher numbered com port and observe debug messages (good).

                But when I attempt to build and load an example from Wiced Studio 6.4.61 I only get the

                "Hello Sensor Start"

                debug message, and nothing else. I scanned for the device using several bluetooth devices and the demo example was not found. I tried this with a number of demo apps with the same result, no bluetooth.

                I could get the snip.hal.gpio example running OK (but it doesn't set up the bluetooth stack, it only makes timer and gpio calls)

                I've attached the build output for the demo.hello_sensor-CYBT_413034_EVAL download target.

                Could you please verify this example will properly load and run on the CYBT-413034-EVAL-02  platform? I cannot proceed further without assistance getting code to run properly on your devices.

                 

                Regards,

                Keith

                • 5. Re: CYBT_413034_EVAL device not detected.
                  KeFo_4700586

                  I have found other posts which describe similar problems with Studio 6.4.0. The solution is to roll back to Studio 6.2.0 and apply the patch for the CYBT-413034 module as described in this solution:

                  CYBT-413034-EVAL EZ-BT Issues with WICED STUDIO V6.4

                   

                  I have done this and now can get the examples to build, load and run correctly.

                  1 of 1 people found this helpful