3 Replies Latest reply on May 14, 2020 2:12 AM by DheerajP_41

    Modustool build Error : rm: cannot remove './.cy_ide_prjname'

    vigb_1229181

      I tried to build BLE-213043EVAL projects with WICED_btsdk present and built in the workspace. None of the projects in the list are being built.

      Error message is as below

       

      How to resolve this?

       

      regards,

      Vinay

        • 1. Re: Modustool build Error : rm: cannot remove './.cy_ide_prjname'
          DheerajP_41

          Hi,

           

          The application builds correctly for me for the target BLE-213043EVAL.

          Also, could you please do a clean (Using quick panel option) and try to build again?

           

          Note, If the software is not installed in the default location, you will need to set an environment variable. Refer to the ModusToolbox Installation Guide for details.

           

          Please let me know below details.

          • Could you please share the Modustoolbox full console logs. (copy and paste the console log into a text file and share here).
          • Could you please share makefile of ANC app.
          • Did you edit MTB workspace folders/structure manually anytime?

           

          I can see that you do not have access to wiced_btsdk folder/files itself. Could you please ensure that you are using the correct workspace and the projects are still associated in that workspace.

          Capture.PNG

           

           

          I would also suggest you to create a new workspace, import wiced_btsdk and then import BLE-213043EVAL application once again. Then try to build and program the apps.

           

          Thanks,

          -Dheeraj

          • 2. Re: Modustool build Error : rm: cannot remove './.cy_ide_prjname'
            vigb_1229181

            Build is successful.

            It is strange though, as I didn't clean or do any changes. Also Readme.md is opening.

            I found that installation is in default location and I had not edited any files or folder structures.

            Build log and makefile is attached(not sure if it can help now).

             

            regards

            Vinay

            • 3. Re: Modustool build Error : rm: cannot remove './.cy_ide_prjname'
              DheerajP_41

              Hi,

               

              So, the application built successfully when you tried second time without clean or any changes/workarounds?

               

              The attached build log doesn't have any errors. Please share the failure log if you can reproduce the issue.

              Build Finished. 0 errors, 0 warnings.

               

              Thanks,

              -Dheeraj

              1 of 1 people found this helpful