1 Reply Latest reply on Apr 18, 2020 1:19 AM by YatheeshK_36

    FX3 SuperSpeed Explorer Kit driver installation is not succesfull under Windows10

    JoJa_2543331

      Hello,

       

      I see the following issue:

      I am not able to install the driver for the FX3 Super Speed Explorer Kit.

      I always see the following issue:

       

      Cypress FX3 USB Bootloader Device

      This security ID may not been assigned as the owner of this object.

      (See screenshot below)

       

      I have Windows 10 version 1709 installed.

      J4 PMODE jumper is set in my setup.

      In device manager the super speed explorer kit is visible as "West bridge" under other devices.

       

      I first tried to install the driver from location: C:\Program Files (x86)\Cypress\EZ-USB FX3 SDK\1.3\driver\bin\Win10\x64

      But it showed the error mentioned.

       

      Because this did not worked I tried the installer from this thread with version 1.2.3.20:

      Re: FX3 driver for windows10

      But it shows the same error.

       

      Can I please get help?

       

      Thank you &

       

      Best regards

        • 1. Re: FX3 SuperSpeed Explorer Kit driver installation is not succesfull under Windows10
          YatheeshK_36

          Hello,

           

          The error is because you have not logged in using the administrator account or you do not have the administrator privileges.

          Refer to this link from Microsoft: Error Message: | Microsoft Docs

           

          In order to bind the device to the cyusb3 driver, you can copy the entire driver folder to a common place, like the documents folder and then manually bind the device to the driver.

           

          Another easier method to install the driver is to use a driver installer:

          Please download the Driver_package.rar file attached to this response and extract in the documents folder and run the dpInstScript.bat file in the package by double clicking on it.

          This will install the required driver from the driver package and the device will automatically bind to the device. Unplug and re-plug the device in case it does not bind to the driver.

           

          Note: The driver package attached in this response contains drivers from the FX3 SDK 1.3.4.

           

          Thanks,

          Yatheesh