3 Replies Latest reply on Jun 22, 2020 12:45 AM by KuCh_1115836

    OTA Incomplete Download

    JoBu_4538421

      Hello,

       

      I am using a Laird Sterling EWB with Wiced Studio 6.4 (Wiced_006.004.000.0061)

       

      I am trying to use OTA to download a new application to the EWB. To do so, I am following the instructions here: https://community.cypress.com/community/wiced-wifi/wiced-wifi-forums/blog/2015/05/22/wiced-ota-sdk-312

       

      Except, instead of trying to download the snip.scan example project, I am trying to download the snip.uart example project.

       

      I can follow all of the steps to completion without any errors. My problem is that after the EWB resets, the OTA program loads up again and is not replaced with the snip.uart example project like I expect.

       

      Here is what the terminal shows:

       

      Here is what the webpage shows:

       

      Attached are the verbose build logs for both the snip.ota_fr and the snip.uart projects.

       

      Any advice or suggestions would be appreciated. Please let me know if you have any questions.

       

      Thanks,

      John

        • 1. Re: OTA Incomplete Download
          RaktimR_11

          I don't have a Sterling EWB with me but I tested with a CY equivalent EVK and don't really hit this issue. Attached is my serial terminal log.

           

          Can you confirm that this issue is only seen when you are trying to upgrade to snip.uart? also I am hoping that you are not trying to boot with the factory reset app which turns out to be ota_fr (I know its stupid to ask but just to get all the bases clarified)...

          • 2. Re: OTA Incomplete Download
            JoBu_4538421

            Hey, thank you for your response. (Also, feel free to ask any stupid questions!)

             

            I don't believe there is a factory reset happening, only a software reset caused by the ota_fr app itself.

             

            I also just tried downloading the snip.scan example project instead of the snip.uart project, and I ran into the same problem. The ota_fr app still loads up after the reset, but I expect the snip.scan app to load up.

             

            I am confused on the OTA process of upgrading the application. Does it first store the binary data in external flash and then copy that to internal flash? If so, why would the bootloader fail to recognize the new flash memory?

             

            Thanks,

            John

            • 3. Re: OTA Incomplete Download
              KuCh_1115836

              Hi RaktimeR_11,

                  the OTA example code would not success result on Laird EWB

                  would you help me to check about Laird bootloader implement?

                   ewb_wiced_demo/bootloader.c at master · LairdCP/ewb_wiced_demo · GitHub