4 Replies Latest reply on Apr 10, 2020 7:27 PM by HuYa_4249091

    Change SDK Include Directories

    HuYa_4249091

      Hi, I've updated the EZ-USB FX3 version to v1.3.4 recently.

      Therefore, I want to update old SDK directories to latest v1.3.4, so I change the "Include directories" in Assembly & GNU C items

      ps. Refer to the setting in SDK v1.3.4 ".\Cypress\EZ-USB FX3 SDK\1.3\firmware\basic_examples\cyfxbulklpautoenum".

      property old assembly.jpg

      property old GNU C.jpg

      property new assembly.jpg

      fig. I've checked that I provided valid ${FX3_INSTALL_PATH} & ${FX3SDKVERSION} which is "1_3_4"

       

      And then, I do "Clean Project" ->  "Build Project", but the SDK file path is still old version...

      cyu3dma.h wrong path.jpg

       

      Besides, in the Project Explorer, I found it still included OLD directories... And It CANNOT modify...

      root path wrong.jpg

       

      Do I miss something need to do?

       

      Best regards,

      Hughes

        • 1. Re: Change SDK Include Directories
          YashwantK_46

          Hello Hughes,

           

          After changing the install path, Please confirm if you have changed the build variable from 1_3_3 to 1_3_4 as below:

          Click on the entry value and you will get a pop-up as below:

          And change the value from 1_3_3 to 1_3_4 and click OK -> Apply -> OK

           

          This will change the build image from 1.3.3 to 1.3.4 and will include the new SDK files.


          "I've checked that I provided valid ${FX3_INSTALL_PATH} & ${FX3SDKVERSION} which is "1_3_4" "

          -- The variable FX3SDKVERSION will be picked from the build variable value that you would need to change as above.

           

          Please "Clean Project" ->  "Build Project" again and check for the include path -- the new path will be taken up by the SDK.

           

          Regards,

          Yashwant

          • 2. Re: Change SDK Include Directories
            HuYa_4249091

            Dear Yashwant:

             

            Thanks for your reply!

            I've confirmed that I've set the correct FX3SDKVERSION path you mentioned.

            In addition, the FX3_INSTALL_PATH is correct(if it's not, I cannot build example "cyfxbulklpautoenum" inside the SDK v1.3.4 installed directory).

            system variables.jpg

             

            After "Clean Project" & "Build Project", the project still use the OLD version SDK...

             

            Therefore, I think there are other reasons for that...

            The attached file is my project, would you please help me to check that?

             

            Thanks a lot!

            Hughes

            • 3. Re: Change SDK Include Directories
              YashwantK_46

              Hello Hughes,

               

              Please do all these steps for your project in Cypress EZ-USB Suite:

              1.) Press Alt+Enter (this will open the project setting dialog box).

              2.) Firstly, add a Build Variable in the C/C++ Build > Build Variable tab as follows:

              3.) Add the library include folder as below in C/C++ General > Paths and Symbols > Assembly tab:

              4.) Add the below settings only as below in the C/C++ General > Paths and Symbols > GNU C tab:

               

              I have added the above settings and after "Clean Project" ->  "Build Project" project, the final folders in the Project Explorer are as follows:


              Please try these on your side and see if you notice the changes.

               

              PS: Remove the entires of the old directory u3p_firmware/inc from the include folders and only keep the ${FX3_INSTALL_PATH} & ${FX3SDKVERSION}

               

              Regards,

              Yashwant

              1 of 1 people found this helpful
              • 4. Re: Change SDK Include Directories
                HuYa_4249091

                Dear Yashwant:

                 

                Thanks for your instruction step by step!

                Finally, I found out the reason:

                I usually use release mode, so I ONLY change the configuration for Release.

                After I do all the same setting to DEBUG mode, the IDE indicates to the 1.3.4 library finally!

                debug.jpg

                 

                Thanks for your help!!

                Hughes

                1 of 1 people found this helpful