2 Replies Latest reply on Apr 5, 2020 4:41 AM by LePo_1062026

    printf()s in a PSoC Creator 4.3 don't always work.

    LePo_1062026

      Hi,

       

      I created two PSoC Creator 4.3 projects in one workspace for the PSoC6 CYBLE-416045-02 on PC "A". I'm also using PDL 3.10.

      In both projects, I use the printf() statements liberally.  Therefore it appears that retargetio is working.

       

      I archived this workspace to move to another PC "B".  I build both projects on PC "B" (using PDL 3.10).  The printf()s are working on one project but not on the other.

      Note:  _PutString()s on either project work OK.

       

      What am I missing?

       

      Len

        • 1. Re: printf()s in a PSoC Creator 4.3 don't always work.
          MoTa_728816

          Hi,

           

          Since both projects are working OK in the PC "A", a

          there should not be errors in the project code.

           

          May be some settings have been changed by accident when you moved them to the PC "B".

           

          I would compare Build Settings > Linker settings of both projects.

          000-build-settings-linker.JPG

          May be re-installing PDL 3.1.0 also affects something.

           

          moto

          P.S. I just noticed, one more thing I would like to try is "Update Components" in the project which is not working.

          • 2. Re: printf()s in a PSoC Creator 4.3 don't always work.
            LePo_1062026

            moto-san,

             

            Thank you for your interest in my question.   You're suggestion wasn't the answer.

             

            As it turns out, the issue appears to be that when I used a copy of the original (working) projects on another PC the build asked if I wanted to remove and in one case rename certain project files I answered "Yes".  That was the issue.  Some of the files that got changed was the  stdio_user.h.  This file is needed to define what SCB to use for the redirection for the printf() calls.  It got defined to a different SCB and that caused the printf() malfunction.

             

            If you're interested, I posted the finished workspace of both projects at:  PSoC6 BLE Beacon and Scanner Creator projects.

             

            Thanks again.

             

            Len

            1 of 1 people found this helpful