3 Replies Latest reply on Apr 6, 2020 4:42 AM by RakshithM_16

    Code Explorer & Go To Declaration not working

    DaSi_4634966

      Hello,

       

      I have a new install of PSoC Creator and I've opened a reference project from the CCGx Power SDK (CYPD3171-24LQXQ_cla). When I open any of the .c or .h files the Code Explorer displays the error "The current document 'Unknown' is not supported for outlining. Supported extensions are: .c, .h, .cpp". main.c is the only open file so shouldn't the Code Explorer work?

       

      Also, when I right click on any function and select "Go To Declaration" (or press F12) nothing happens. It does not go to the function declaration and there is no error message.

       

      Some more info:

      -The project compiles OK

      -Options->Text Editor->Inline Diagnostics & Autocomplete -> Enable semantic parsing (checked)

       

      PSoC Creator: 4.3.0.1445
      Windows 10 Enterprise Version 1809

       

      Thanks,

      Daryl

        • 1. Re: Code Explorer & Go To Declaration not working
          RakshithM_16

          Hi DaSi_4634966,

           

          I have installed EZPDCCGxPowerSDK and opened the workspace present in this directory - C:\Program Files (x86)\Cypress\EZ-PD CCGx Power SDK\CCGx\Firmware\projects\CYPD3171-24LQXQ_cla. I was able to open the .c and .h files in the project as shown -

          I tried the Go To Declaration option and the pointer went to the function declaration in the .h file as expected. I am using the PSoC Creator 4.3.0.1445 as well.

           

          Can you please provide more information regarding your setup so that we can try and reproduce the issue?

          1. The installation procedure that you followed.

          2. The setup version, installation directory of both the SDK and PSoC Creator.

          3. The file and function that you have mentioned in your query.

          4. Is the issue restricted to only this project or any PSoC Creator project in general?

          5. Please share a screenshot of the error and the PSoC Creator output log.

           

          Thanks and Regards,

          Rakshith M B

          • 2. Re: Code Explorer & Go To Declaration not working
            DaSi_4634966

            Hello Rakshith,

            Thank you for looking into this.

             

            1. I started by installing the CCGx Host SDK v3.3.1 Installer (which includes PSoC Creator 4.2) from https://www.cypress.com/documentation/software-and-drivers/ez-pd-host-software-development-kit

            I realized I needed the Power SDK and not the Host SDK, so I installed the CCGx Power SDK v3.4 Setup Only Package from https://www.cypress.com/documentation/software-and-drivers/ez-pd-ccgx-power-software-development-kit

            This problem occurred, so I installed PSoC Creator 4.3 to eliminate the possibility of bugs in the older 4.2 version.

            2. Directory structure can be seen here:

            Directory.JPG

            3 . All files and all functions

            4.  Here I have some new information to add. When I am working at home (because of COVID-19) all projects have the same problem (new blank projects or code examples). I was in the office this morning and the Code Explorer and Go To Declaration worked OK for all projects. Now I am back home and it stopped working again.

             

            Our company computers use Direct Access when we work remotely. Direct Access uses IPv6 only which has caused problems with other software. I have found that these features work OK in PSoC Creator if I disable Direct Access while at home. This is very strange because all my projects are stored on my local drive, so why does an IPv6 Direct Access connection affect PSoC Creators ability to parse local files?

             

            I will continue with this work-around for now, but it is very inconvenient to be isolated from my corporate network and email all day while I am developing software. Any input would be greatly appreciated!

             

            Regards,

            Daryl

            • 3. Re: Code Explorer & Go To Declaration not working
              RakshithM_16

              Hi DaSi_4634966,

               

              Thank you for bringing this to our notice.

               

              Can you try using PSoC Creator 4.0 and let me know if you are able to find the same issue in PSoC Creator 4.0 too?

               

              I have raised an internal ticket to look into this error. They will be evaluating this issue and they will be fixing it in future releases.

               

              Thanks and Regards,

              Rakshith M B