2 Replies Latest reply on Mar 28, 2020 4:17 AM by AnjanaM_61

    CYBT-413034-02: "LE Set Scan Parameters Command" returns "COMMAND DISALLOWED (0x0C)"

    AnHu_4662101

      Hi,

       

      Tryin to configure the LE Scan params for my CYBT-413034-02 device returns:

      Status: Command Disallowed (0x0c)
      

       

      Complete command is:

      hcitool cmd 0x08 0x000B 0x01 0x04 0x00 0x04 0x00 0x01 0x00
      

       

      Trace:

      < HCI Command: LE Set Scan Parameters (0x08|0x000b) plen 7 #1 [hci0] 2.327627
        Type: Active (0x01)
        Interval: 2.500 msec (0x0004)
        Window: 2.500 msec (0x0004)
        Own address type: Random (0x01)
        Filter policy: Accept all advertisement (0x00)
      > HCI Event: Command Complete (0x0e) plen 4 #2 [hci0] 2.331126
         LE Set Scan Parameters (0x08|0x000b) ncmd 1
        Status: Command Disallowed (0x0c)
      @ RAW Close: hcitool  {0x0003} [hci0] 2.331223
      

       

      Thanks.

        • 1. Re: CYBT-413034-02: "LE Set Scan Parameters Command" returns "COMMAND DISALLOWED (0x0C)"
          AnHu_4662101

          Actually resetting the dongle before this command makes the command work.

          hcitool cmd 0x03 0x0003
          

           

          Complete trace:

          @ RAW Open: hcitool (privileged) version 2.22 {0x0003} [hci0] 2.009234
          < HCI Command: LE Set Scan Parameters (0x08|0x000b) plen 7 #1 [hci0] 2.009534
            Type: Active (0x01)
            Interval: 2.500 msec (0x0004)
            Window: 2.500 msec (0x0004)
            Own address type: Random (0x01)
            Filter policy: Accept all advertisement (0x00)
          > HCI Event: Command Complete (0x0e) plen 4 #2 [hci0] 2.013290
             LE Set Scan Parameters (0x08|0x000b) ncmd 1
            Status: Command Disallowed (0x0c)
          @ RAW Close: hcitool  {0x0003} [hci0] 2.013419
          @ RAW Open: hcitool (privileged) version 2.22 {0x0003} 4.485877
          @ RAW Close: hcitool  {0x0003} 4.486335
          @ RAW Open: hcitool (privileged) version 2.22 {0x0003} [hci0] 4.486409
          < HCI Command: Reset (0x03|0x0003) plen 0 #3 [hci0] 4.486593
          > HCI Event: Command Complete (0x0e) plen 4 #4 [hci0] 4.492259
             Reset (0x03|0x0003) ncmd 1
            Status: Success (0x00)
          @ RAW Close: hcitool  {0x0003} [hci0] 4.492369
          @ RAW Open: hcitool (privileged) version 2.22 {0x0003} 5.421909
          @ RAW Close: hcitool  {0x0003} 5.421981
          @ RAW Open: hcitool (privileged) version 2.22 {0x0003} [hci0] 5.422055
          < HCI Command: LE Set Scan Parameters (0x08|0x000b) plen 7 #5 [hci0] 5.422349
            Type: Active (0x01)
            Interval: 2.500 msec (0x0004)
            Window: 2.500 msec (0x0004)
            Own address type: Random (0x01)
            Filter policy: Accept all advertisement (0x00)
          > HCI Event: Command Complete (0x0e) plen 4 #6 [hci0] 5.426316
             LE Set Scan Parameters (0x08|0x000b) ncmd 1
            Status: Success (0x00)
          @ RAW Close: hcitool  {0x0003} [hci0] 5.426559
          
          • 2. Re: CYBT-413034-02: "LE Set Scan Parameters Command" returns "COMMAND DISALLOWED (0x0C)"
            AnjanaM_61

            Yes, That's correct. You have to send HCI reset command first and see if you are getting a success response.

            Then only you should proceed with next commands.

             

            Regards,

            Anjana

            1 of 1 people found this helpful