3 Replies Latest reply on Mar 22, 2020 9:35 AM by JeSi_4326976

    PSOC 6 Pioneer kit: no debug targets available

    JeSi_4326976

      Hi,

      I recently started having problems with my PSoC 6 Pioneer kit (CY8CKIT-062-BLE). I have been using it successfully since September 2019. Since before yesterday, when I click on the program button, the Select debug target window appears, I am able to see my KitProg 3, but the 2 options I used to be able to choose (Cortex M4 and M0+) are just gone, they do not appear anymore, so I cannot program my kit anymore.

       

      I am using CYC6347BZI-BLD53 (Y w/ gestures) in the device selector. I tested on both the computers I have been using in the past month and none work. I am sure it a question of programming mode of the device, or firmware or driver. I just didn't find a post addressing this family of devices yet. I have read pressing the reset button 10s could help but it didn't work for me. I also made sure there was no other program using the kit when plugged in, as this seemed to be one common problem with this issue. I went to PSoC programmer app and the device was properly recognized and connected. I clicked on upgrade firmware and it worked, but still no use. After a full day of programming, I had 2 instances of usb device not recognized or malfunctioned when replugging the kit to my PC. Those 2 happened like in the last 10 tries I have made. The kit  is still recognized most of the time but this worried me quite a bit.

       

      Could it be a hardware problem?? I hope not, it would be very surprising as I am not carrying the kit around. I am sure there is a way to change the programming mode or whatnot of this device? thanks!