5 Replies Latest reply on Mar 24, 2020 7:45 AM by RakshithM_16

    Miniprog 4 & CLI /ppcli.exe OpenPort Fehler

    KlMu_4151301

      Hallo Zusammen,

      wir möchten den Minprog 4 über das CLI Interface ansteuern.

      Das Öffnen des Ports mit dem OpenPort-Befehl scheitert aber.

      Hier die Meldung von der ppcli.exe...

      Can not open port "MiniProg4". It is not connected.

      OpenPort MiniProg4 (CMSIS-DAP/BULK/0F0317C800287400) . returned 80004005

       

      80004005 OK
      GetPorts liefert folgrendes ...
      C:\Program Files (x86)\Cypress\Programmer\ppcli.exe "--GetPorts" --quit

      MiniProg4 (CMSIS-DAP/BULK/0F0317C800287400)

      MiniProg4 (Bridge/0F0317C800287400)

      0 OK

      <OK

       

      Hat jemand eine Ahnung was hier falsch laufen könnte ?

      Über die Programmer-Software können wir programmieren und wir nutzen die allerneuste Software (PSoCProgrammerSetup_3.28.6_b4409.exe)

       

      Danke !

        • 1. Re: Miniprog 4 & CLI /ppcli.exe OpenPort Fehler
          RakshithM_16

          Hi KlMu_4151301,

           

          Please use the following command -

           

          OpenPort "MiniProg4 (CMSIS-DAP/BULK/0F0317C800287400)" .

           

           

          Hope this helps,

           

          Thanks and Regards,

          Rakshith M B

          • 2. Re: Miniprog 4 & CLI /ppcli.exe OpenPort Fehler
            KlMu_4151301

            Hello Rakshith M B,

            thanks for your quick answer.

            When we use the shell (cmd.exe) and send the command direct, it works !

            But we use a batchfile with parameters.

            The Miniprog 3 Version works, Miniprog 4 don't work.

             

            with MiniProg3: (works fine)

            ====================================

            Call:

            C:\Program Files (x86)\Cypress\Programmer\ppcli.exe "--OpenPort MiniProg3/1745CA00043A ." --quit

            Response:

            <
            0 OK
            <OK

             

            Miniprog 4

            ===========

            Variant 1:

            Call:

            C:\Program Files (x86)\Cypress\Programmer\ppcli.exe --OpenPort "MiniProg4 (CMSIS-DAP/BULK/0F0317C800287400)" --quit

            Response:

            <
            Not enough inputs to OpenPort
            OpenPort returned 80004005
            80004005 OK
            <OK
            ____________________________________________________________________________________________________________________________

            Variant 2:

            Call:

            C:\Program Files (x86)\Cypress\Programmer\ppcli.exe "--OpenPort "MiniProg4 (CMSIS-DAP/BULK/0F0317C800287400)" ." --quit

            Response:

            <
            Not enough inputs to OpenPort
            OpenPort MiniProg4 returned 80004005
            80004005 OK
            <OK

            ____________________________________________________________________________________________________________________________

            Variant 3:

            Call:

            C:\Program Files (x86)\Cypress\Programmer\ppcli.exe "--OpenPort MiniProg4 (CMSIS-DAP/BULK/0F0317C800287400) ." --quit

            Response:

            E
            Can not open port "MiniProg4". It is not connected.
            OpenPort MiniProg4 (CMSIS-DAP/BULK/0F0317C800287400) . returned 80004005
            80004005 OK
            <OK

             

            Thanks

            Klaus

            • 3. Re: Miniprog 4 & CLI /ppcli.exe OpenPort Fehler
              RakshithM_16

              Hi KlMu_4151301,

               

              Can you please let me know if there is any particular reason why you would want to run the API by providing commands to the ppcli?

              This method is throwing an error as it finds a space in between the MiniProg4 port name and the conflict between the " " signs.

               

              Can you try passing a script file to ppcli instead? I have attached a script file with the 3 commands. Please modify the script file accordingly.

              You can pass the file to ppcli using the command -

              ppcli "--runfile script.cli"

               

               

              Hope this helps,

               

              Thanks and Regards,

              Rakshith M B

              • 4. Re: Miniprog 4 & CLI /ppcli.exe OpenPort Fehler
                KlMu_4151301

                Hello Rakshith M B,

                Ok, we use the script, this part now runs.

                The next problem ist that we get an error with the DAP_ReleaseChip command.

                With Miniprog 3 works

                 

                See following pictures ...

                ppcli_ReleaseError.png

                ppcli_FlashSettings.png

                ppcli_FlashSettings.pngppcli_ReleaseError.png

                 

                Thank you very much !!!!!!!!!!!!!!!!!!!!!!!!

                Klaus

                • 5. Re: Miniprog 4 & CLI /ppcli.exe OpenPort Fehler
                  RakshithM_16

                  Hi KlMu_4151301,

                   

                  I was not able to reproduce this issue. Can you please attach the PSoC Creator project and the .cli file used to program the device so that I can try to debug the issue?

                   

                  Also, can you let me know the PSoC Programmer version that you installed on you PC? If you do not have the latest version installed please update your PSoC Programmer and let me know if you still face the same issue.

                   

                  Thanks and Regards,

                  Rakshith M B