2 Replies Latest reply on Mar 11, 2020 10:05 PM by RashiV_61

    JLinkGDBServer doesn't find my CYUSB3KIT-003

    LuTa_4642501

      Jlink server doesn't find my board:

       

      JLinkGDBServer -device ARM9

      SEGGER J-Link GDB Server V6.62d Command Line Version

       

       

      JLinkARM.dll V6.62d (DLL compiled Mar  2 2020 09:23:31)

       

       

      Command line: -device ARM9

      -----GDB Server start settings-----

      GDBInit file:                  none

      GDB Server Listening port:     2331

      SWO raw output listening port: 2332

      Terminal I/O port:             2333

      Accept remote connection:      yes

      Generate logfile:              off

      Verify download:               off

      Init regs on start:            off

      Silent mode:                   off

      Single run mode:               off

      Target connection timeout:     0 ms

      ------J-Link related settings------

      J-Link Host interface:         USB

      J-Link script:                 none

      J-Link settings file:          none

      ------Target related settings------

      Target device:                 ARM9

      Target interface:              JTAG

      Target interface speed:        4000kHz

      Target endian:                 little

       

       

      Connecting to J-Link...

      Connecting to J-Link failed. Connected correctly?

      GDBServer will be closed...

      Shutting down...

      Could not connect to J-Link.

      Please check power, connection and settings.

       

      Result of lsusb:

      Bus 004 Device 002: ID 8087:8002 Intel Corp.

      Bus 004 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

      Bus 001 Device 002: ID 8087:800a Intel Corp.

      Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

      Bus 003 Device 003: ID 17aa:1034 VIA Labs, Inc.          USB Hub               

      Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub

      Bus 002 Device 002: ID 17aa:1034 VIA Labs, Inc.          USB Hub               

      Bus 002 Device 020: ID 04b4:0007 Cypress Semiconductor Corp. USB-Serial (Dual Channel)

      Bus 002 Device 021: ID 04b4:00f3 Cypress Semiconductor Corp. WestBridge

      Bus 002 Device 005: ID 0424:2514 Microchip Technology, Inc. (formerly SMSC) USB 2.0 Hub

      Bus 002 Device 004: ID 045e:0745 Microsoft Corp. Nano Transceiver v1.0 for Bluetooth

      Bus 002 Device 003: ID 0424:2514 Microchip Technology, Inc. (formerly SMSC) USB 2.0 Hub

      Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

       

      My kernel:

      Linux archtower 5.5.8-arch1-1 #1 SMP PREEMPT Fri, 06 Mar 2020 00:57:33 +0000 x86_64 GNU/Linux

        • 1. Re: JLinkGDBServer doesn't find my CYUSB3KIT-003
          LuTa_4642501

          Another try that doesn't work:

           

          /opt/SEGGER/JLink/JLinkGDBServer -if jtag -device ARM9 -endian little -speed 1000 -port 2331 -swoport 2332 -telnetport 2333 -vd -ir -localhostonly 1 -singlerun -strict -timeout 0 -nogui SEGGER J-Link GDB Server V6.62d Command Line Version

           

           

          JLinkARM.dll V6.62d (DLL compiled Mar  2 2020 09:23:31)

           

           

          Command line: -if jtag -device ARM9 -endian little -speed 1000 -port 2331 -swoport 2332 -telnetport 2333 -vd -ir -localhostonly 1 -singlerun -strict -timeout 0 -nogui

          -----GDB Server start settings-----

          GDBInit file:                  none

          GDB Server Listening port:     2331

          SWO raw output listening port: 2332

          Terminal I/O port:             2333

          Accept remote connection:      localhost only

          Generate logfile:              off

          Verify download:               on

          Init regs on start:            on

          Silent mode:                   off

          Single run mode:               on

          Target connection timeout:     0 ms

          ------J-Link related settings------

          J-Link Host interface:         USB

          J-Link script:                 none

          J-Link settings file:          none

          ------Target related settings------

          Target device:                 ARM9

          Target interface:              JTAG

          Target interface speed:        1000kHz

          Target endian:                 little

           

           

          Connecting to J-Link...

          Connecting to J-Link failed. Connected correctly?

          GDBServer will be closed...

          Shutting down...

          Could not connect to J-Link.

          Please check power, connection and settings.

          • 2. Re: JLinkGDBServer doesn't find my CYUSB3KIT-003
            RashiV_61

            Hello,

             

            As you are using CYUSB3KIT -003 which can be debugged using OpenOCD and not JLink Segger.

            Please refer to FX3_SDK_Linux_support.pdf  and follow the steps mentioned in section 4.2 to debug the kit

             

            Regards,

            Rashi