7 Replies Latest reply on Feb 28, 2020 12:34 AM by AnjanaM_61

    Program CYW920819 eval board with J-Link

    user_1536336

      I just want to program my new CYW920819 eval board (20819 silicon) with the Modus Toolbox 2.0. I tried this with the J-Link Plus Version 10.1 without success.

       

      Project explorer

      Project.PNG

       

      Debug configuration

      Debug.PNG

      debugger.PNG

       

      Error

      error0.PNG

       

      Console output

      Could not connect to target.

      Please check power, connection and settings.SEGGER J-Link GDB Server V6.54c Command Line Version

       

       

      JLinkARM.dll V6.54c (DLL compiled Nov  7 2019 17:01:02)

       

       

      Command line: -if swd -device Cortex-M4 -endian little -speed auto -port 2331 -swoport 2332 -telnetport 2333 -noreset -noir -localhostonly 1 -singlerun -strict -timeout 0 -nogui

      -----GDB Server start settings-----

      GDBInit file:                  none

      GDB Server Listening port:     2331

      SWO raw output listening port: 2332

      Terminal I/O port:             2333

      Accept remote connection:      localhost only

      Generate logfile:              off

      Verify download:               off

      Init regs on start:            off

      Silent mode:                   off

      Single run mode:               on

      Target connection timeout:     0 ms

      ------J-Link related settings------

      J-Link Host interface:         USB

      J-Link script:                 none

      J-Link settings file:          none

      ------Target related settings------

      Target device:                 Cortex-M4

      Target interface:              SWD

      Target interface speed:        auto

      Target endian:                 little

       

       

      Connecting to J-Link...

      J-Link is connected.

      Firmware: J-Link V10 compiled Nov  8 2019 16:40:12

      Hardware: V10.10

      S/N: 600100325

      Feature(s): RDI, FlashBP, FlashDL, JFlash, GDB

      Checking target voltage...

      Target voltage: 3.28 V

      Listening on TCP/IP port 2331

      Connecting to target...ERROR: Could not connect to target.

      Target connection failed. GDBServer will be closed...Restoring target state and closing J-Link connection...

      Shutting down...

      So it seems, that there can't be established  a connection with the Board and my J-Link. I already tried to switch off SW 9 and to remove all four jumpers for the PUART connection interface. Is there anythink elese I could do?

       

      Best Regards!