2 Replies Latest reply on Feb 13, 2020 8:03 AM by ErGo_4573391

    PyOCD timeout

    ErGo_4573391

      Hello, I am using  a CY8CKIT-062-BLE with mbed Os in DapLink Mode. I can load programs to the board throught the CMD (Windows) with the comand:

      "mbed compile -m CY8CKIT_062_BLE -t GCC_ARM -f"

      And it works correctly, but I when I use the ModusToolBox I get this problem when I run the program.

       

       

      PyOCD_timeout.PNG

       

      "Error in services launch sequence

      Starting pyOCD GDB Server timed out."

       

      Thanks in advance.

       

      Ernesto Gomez Marin.

        • 1. Re: PyOCD timeout
          DheerajK_81

          Hello Ernesto,

           

          Please follow these steps to get it working:

           

          (1) Upgrade pyocd to the latest version based on the version listed here

          >> pip install pyocd==0.24.1

           

          (2) Install libusb library package required for CMSIS-DAPv2 Probes (such as Kitprog3). Download libusb from libusb.info and place the DLL in your Python installation folder next to python.exe. Make sure to use the same 32- or 64-bit architecture as your Python installation. Note: due to a known issue, the current recommendation is to use libusb version 1.0.21 on Windows instead of the most recent version.

           

          (3) In ModusToolbox, go to Run >  Debug Configurations. Select the debug configuration for the project as shown below:

          openocd1.png

          Add the Override Target as "cy8c6xx7" which is the device on the PSoC6 BLE Pioneer Kit under the Debugger tab.

           

          (4) Under the Startup tab, in the Load executable option, point to the hex file instead of the elf file as shown:

          openocd2.png

           

          (5) Click Apply. Change the Kitprog3 mode to HID/DAPLink and then run Debug.

           

          You should no longer see the errors. Let me know your observations

           

          Regards,

          Dheeraj

          1 of 1 people found this helpful
          • 2. Re: PyOCD timeout
            ErGo_4573391

            It solved my problem, thanks. Now the debugger works perfectly (a bit slow, but it works)