2 Replies Latest reply on Feb 13, 2020 12:41 AM by SuMa_296631

    BLE project always has Immediate Alert and Device Information but not my services

    SuMa_296631

      I am trying to create a minimal BLE app for the CYBLE-416045-02. I amusing the latest PSoC Creator and PDL V3.1.1.

      The problem I am having is that when the app runs, it broadcasts the 'Immediate Alert' and 'Device Information' services. However these are NOT defined in the BLE component.

      The 'device name' is correct.

      It seems as though it is correctly picking up the GAP settings but not the GATT settings.

      I've tried to uninstall the PSoC Creator and all other programs and reinstall them; the Updater tools shows everything at the latest version.

      I've tried to create a new project; delete everything else from the workspace; delete all of the workspaces to see if there was some strange cross-over from some other application. Nothing stops the created app form just having the 2 services that I don't mention and none of the ones I do!

      I've attached an archive of my app.

      This is driving me nuts (and slowing down my work!).

      ANy pointers as to what I'm doing wrongly would be appreciated.

      Susan