1 Reply Latest reply on Feb 9, 2020 7:02 PM by YuxianL_01

    ModusToolbox showing an error after programming in release mode - Solution

    SuMa_296631

      This follows on from another thread that I started (miniprog4 cannot find cy8cproto-063-ble or my proc6 board ) but which is now locked so I cannot provide the resolution that I have discovered.

      [Quick summary - I switched to ModusToolbox V2 and a MiniProg4 but could not program my custom circuit board; eventually I could program my CY8CPROTO-063-BLE board.]

      It turns out that there were two problems with my board. One was that the capacitors on my WCO crystal were too small (the crystal required a load capacitance of 6pF and so I used 2 x 10pF capacitors - I needed to use 2 x 22pF capacitors) and so the WCO was not starting. This took the code to the 'cycfg_ClockStartupError' function. However any program that didn't use the WCO worked well in 'debug' mode.

      The other situation was that there was a dry joint on the 'XRES' pin (pin 42) so that when the MiniProg4 tried to do a reset after the programming so that the program woudl run, it detected that the reset was not effective and so reported the error:

       

      ** Program operation completed successfully **

      srst_only separate srst_gates_jtag srst_open_drain connect_deassert_srst

      target halted due to breakpoint, current mode: Thread

      xPSR: 0x61000000 pc: 0x0800000c msp: 0x08000870

      Error: psoc6.cpu.cm4 -- clearing lockup after double fault

      target halted due to debug-request, current mode: Handler HardFault

      xPSR: 0x61000003 pc: 0x8008f3ee msp: 0x080477e0

      Polling target psoc6.cpu.cm4 failed, trying to reexamine

      Info : psoc6.cpu.cm4: hardware has 6 breakpoints, 4 watchpoints

      shutdown command invoked

       

      After I fixed the dry solder joint it now gives:

       

      ** Program operation completed successfully **

      srst_only separate srst_gates_jtag srst_open_drain connect_deassert_srst

      Info : SWD DPIDR 0x6ba02477

      Info : psoc6.cpu.cm0: external reset detected

      Info : psoc6.cpu.cm4: external reset detected

      shutdown command invoked

       

      and the program run as expected.

      I hope this might help someone else with this problem (which is not obvious - at least to me - from the error message).

      So thank you to all who helped to get the correct configuration commands and my apologies for taking the conversation down a false pathway.

      Susan