1 2 Previous Next 19 Replies Latest reply on Dec 26, 2019 7:09 PM by XinghaoZ_26

    HCI uart cannot recieve any data when recieve bad data which format is not same as WICED HCI UART Control Protocol

    YaTr_3516311

      Hi,

       

      I'm testing HCI uart function which recieve data command. When test use "19 01 01 02 00 01 01"(scan) command. It is fine( Debug trace shown hci_control_process_rx_cmd : Data Length '6). But when I test data which is not done as WICED HCI UART Control Protocol, use "00 01 01 33 55 65", "hci_control_process_rx_cmd : Data Length"  debug trace not shown. And after that I use nomarl command ""19 01 01 02 00 01 01"(scan)", debug trace still not shown and I tried many times. No this trace come even I input normal format command.

      1. Debug trace shown the len is not calculated 19 byte. Right? Because I input 7 bytes command(19 01 01 02 00 01 01), and this log shown len is 6.

      2. I test abnormal command because I worried that there will be useless data been received by this uart. And I want this uart still can work normal, still can recieve data. But unfortunatelly, it works not fine. And even I send normal format command, it still cannot receive data(Because no debug trace shown). How to fix this problem? Attach is my code. Please have a check

        1 2 Previous Next