7 Replies Latest reply on Dec 21, 2019 2:53 AM by LePo_1062026

    Compiling error that I can not find

    ScCl_3419596

      I keep getting these errors noted below.  How do i get rid of them when i can not find them.  Also the component I made give me a warning, is there a way I can ix this also.

        • 1. Re: Compiling error that I can not find
          MoTa_728816

          Hi,

           

          I downloaded your zip but there was no source/header files so I could not try compiling.

           

          Could you do follow?

          (1) Select the project in Workspace Exploere

          (2) Menu Build > Clean <project>

          (3) Menu Project > Archive Workspace/Project...

          Attach result zip file

           

          moto

          • 2. Re: Compiling error that I can not find
            ScCl_3419596

            I did as you suggested Motoo ... Scott

            • 3. Re: Compiling error that I can not find
              LePo_1062026

              Scott,

               

              Both the .zip file archives you sent only have a .pdf, the workspace file (.cywrk) and personal workspace file.  Not enough to work with.

              Are you sure you're using the Project Archive feature in PSoC Creator?  (See Below)

               

              Len

              • 4. Re: Compiling error that I can not find
                ScCl_3419596

                Len,

                I did use both the bundle under File the achiever under Project.  I could not get all the files to be made and bundled properly.  So i took my project file straight from my directory and loaded into my buddy's PC  and had him compile the project.  He was able to compile it with not errors or warnings.  I then took his raw project directory and wrote right over mine with the same file mind you with not changes not even the name. I then complied the project and i got not errors also.  This was very frustrating i don't know why.  I will attach my project ( a zipped file of my project directory for your review hopefully there can be something found to indicate what i am doing wrong. Below are two screen shots of what i used to do the bundling in File and under Project(Note i could not get either to work properly.

                 

                Scott

                 

                • 5. Re: Compiling error that I can not find
                  ScottA_91

                  Would you please expand the error location?  Alternatively, does double clicking the error take you to the right location?

                  • 6. Re: Compiling error that I can not find
                    MoTa_728816

                    Hi,

                     

                    I downloaded and tried your last attachment "Injection Machine DV1.cydsn.zip"

                    It had only Injection_Machine_DV1" project and it compiled OK.

                    000-Injection_Machine_DV1_OK.JPG

                    Then I noticed that there is a zip file "Injection Molder.cywrk.Archive01.zip" in the project folder.

                    If you were using standard "Archive Workspace/Project..." menu, this kind of zip should be generated in an Archive folder, so I think that you are doing something original or different.

                     

                    Anyway, I expanded the project and tried to open it, then got following error dialog

                    002-Injection_Molder_Error.JPG

                    in the meantime, PSoC Creator output  was

                    003-Injection_Molder_output.JPG

                    It says that

                    (1) "C:\Driver Projects\SS1-Injection Molder\Firmware\Injection Machine DV1.cydsn\Injection Machine DV1.cyprj" can not be opened

                    (2) "C:\Cypress Examples\OLED.cydsn\OLED.cyprj" can not be opened

                     

                    So, for (1) I moved "Injection Machine DV1.cydsn" to "C:\Driver Projects\SS1-Injection Molder\Firmware\

                    Then tried Injection Molder again,

                    This time I only got error for OLED.

                    And as you have your implementation of OLED in the Injection Machine DV1.cydsn,

                    I just "Removed OLED from the project"

                    004-2nd-trial.JPG

                     

                    Then I tried to Clean and Build "Injection_Molder" again and this time I could be compiled OK.

                    005-Injection_Molder_2nd.JPG

                     

                    From your original post, it seemed that the INJ pin of ADC was not connected,

                    and also there was a conflict between your "OLED" and Cypress's sample "OLED".

                     

                    But the current attached project does not have ADC pin problem.

                    And if I remove Cypress's sample "OLED" from the project, it can be compiled

                    so it will be difficult to find a problem in the current project.

                     

                    A couple of suggestions/requests

                    (1) Please do not have space ' ' or dash '-' in the middle of your project path.

                       Although it could be compiled, IMHO, this can be a very good source of problems.

                    (2) If you have scattered projects please provide all projects so that we can reproduce same problem.

                     

                    moto

                    • 7. Re: Compiling error that I can not find
                      LePo_1062026

                      Scott,

                       

                      Downloaded your proejct.  Builds and compiles with no errors.

                       

                      Len