10 Replies Latest reply on Feb 4, 2020 8:13 PM by RoCh_2868046

    Murata LBEE5HY1MW : i.MX6ULL Bringup

    KeKu_4607161

      We are trying to test LBEE5HY1MW with our custom i.MX6ULL board.

      Here is the setup:

      Hardware:

      • Wired M2.connector type EVK's SDIO pins to  to our Board.
      • Wired WL_REG_ON, WL_HOST_WAKE, BT_REG_ON to our board and configured as GPIOs.
      • Wired BT_UART_TXD, BT_UART_RXD to our board.
      • Power to LBEE5HY1MW M2.connector type EVK is from SDIO Vcc.

      SDIO  voltage is set to 3.3V. (Attached[HW_Setup.JPEG] image for reference)
      Software:

       

      After successful build of backport drivers, trying to insmod the driver. But we are not getting wlan0 after registered new interface driver brcmfmac print.

      As per Cypress community pages WiFi Firmware should load after registering brcmfmac and wlan0 interface should come up. But unfortunately we are not getting these prints.

      All required firmware files are available in mentioned path (https://community.cypress.com/docs/DOC-14597) [/lib/firmware/brcm/]

      To debug further on the issue, we tried to power EVK through USB and tried configuring SDIO in-band interrupts. But still observing same issue.

      Attached bootlog and testing results for reference

      Please help us to resolve this issue as soon as possible.