3 Replies Latest reply on Dec 22, 2019 6:18 PM by ZhengbaoZ_96

    Problem with 1MW Murata WiFi+BT on custom imx6ull board

    KeKu_4607161

      Dear All,

      I am trying to use 1MW Murata WiFi+BT EVK on custom i.MX6ULL board.

      I have wired SDIO to the EVK and have connected WL_REG_ON , WL_IRQ and BT_REG_ON to CPU IOs.

      Currently I am using 4.1.15 kernel and this kernel comes with brcm,bcm4329-fmac driver.

      I am trying to make 1MW WiFi and BT Up.

      But I always get below message when making WLAN up:

      root@root~# ifconfig wlan0

      wlan0: error fetching interface information: Device not found

      root@iWave-G26P:~# iw dev

      root@iWave-G26P:~#

      Here are the changes I have done:

      Device Tree:

      &usdhc1 {

              #address-cells = <1>;

              #size-cells = <0>;

       

              pinctrl-names = "default";

              pinctrl-0 = <&pinctrl_wifi>;

              non-removable;

              wifi-host;

              no-1-8-v;

              vmmc-supply = <&reg_sd1_vmmc>;

              vqmmc-supply = <&reg_3p3v>;

              voltage-ranges = <3200 3400>;

              non-removable;

              pm-ignore-notify;

              status = "okay";

       

              brcmf: bcrmf@1 {

                      reg = <1>;

                      compatible = "brcm,bcm4329-fmac";

                      interrupt-parent = <&gpio3>;

                      interrupts = <0 IRQ_TYPE_LEVEL_LOW>;

                      interrupt-names = "host-wake";

              };

       

      };

                      pinctrl_wifi: wifigrp {

                              fsl,pins = <

                                      MX6UL_PAD_SD1_DATA0__USDHC1_DATA0      0x1b0b0

                                      MX6UL_PAD_SD1_DATA1__USDHC1_DATA1      0x1b0b0

                                      MX6UL_PAD_SD1_DATA2__USDHC1_DATA2      0x1b0b0

                                      MX6UL_PAD_SD1_DATA3__USDHC1_DATA3      0x1b0b0

                                      MX6UL_PAD_SD1_CLK__USDHC1_CLK          0x1b0b0

                                      MX6UL_PAD_SD1_CMD__USDHC1_CMD          0x1b0b0

                                      /*WL REG ON */

                                      MX6UL_PAD_LCD_DATA21__GPIO3_IO26       0x1b0b0

                                      /* WL HOST WAKE */

                                      MX6UL_PAD_LCD_CLK__GPIO3_IO00          0x1b0b0

       

                              >;

                      };

       

                      pinctrl_bluetooth: bluetoothgrp {

                              fsl,pins = <

                                     MX6UL_PAD_UART4_TX_DATA__UART4_DCE_TX     0x1b0b0

                                     MX6UL_PAD_UART4_RX_DATA__UART4_DCE_RX     0x1b0b0

                                     /* BT REG ON*/

                                     MX6UL_PAD_LCD_DATA20__GPIO3_IO25          0x130b0

                              >;

       

                      reg_sd1_vmmc: regulator@1 {

                              compatible = "regulator-fixed";

                              regulator-name = "VSD_3V3";

                              regulator-min-microvolt = <3300000>;

                              regulator-max-microvolt = <3300000>;

                              gpio = <&gpio3 26 GPIO_ACTIVE_HIGH>;

                              enable-active-high;

                      };

       

                      reg_3p3v: 3p3v {

                              compatible = "regulator-fixed";

                              regulator-name = "3P3V";

                              regulator-min-microvolt = <3300000>;

                              regulator-max-microvolt = <3300000>;

                              regulator-always-on;

                      };

       

      Below is the Boot Print of SDIO:

      sdhci: Secure Digital Host Controller Interface driver

      sdhci: Copyright(c) Pierre Ossman

      sdhci-pltfm: SDHCI platform and OF driver helper

      sdhci-esdhc-imx 2190000.usdhc: assigned as wifi host

      mmc0: SDHCI controller on 2190000.usdhc [2190000.usdhc] using ADMA

      usbcore: registered new interface driver usbhid

      usbhid: USB HID core driver

      2198000.adc supply vref not found, using dummy regulator

      mmc0: queuing unknown CIS tuple 0x80 (2 bytes)

      mmc0: queuing unknown CIS tuple 0x80 (3 bytes)

      mmc0: queuing unknown CIS tuple 0x80 (3 bytes)

      mmc0: queuing unknown CIS tuple 0x80 (7 bytes)

      mmc0: queuing unknown CIS tuple 0x80 (6 bytes)

      mmc0: queuing unknown CIS tuple 0x91 (3 bytes)

      mmc0: new high speed SDIO card at address 0001

      NET: Registered protocol family 26

      Netfilter messages via NETLINK v0.30.

       

      I am not getting any other prints regarding brcmfmac driver. I have enabled all the CONFIG required in kernel.

      I am referring https://wireless.murata.com/pub/RFM/data/murata_quick_start_guide_linux.pdf  link, but I not getting any other prints explained in Section 7(Page 33).

       

      I also tried to make brcmfmac is ko and tried to insmod by using below command:

      insmod  brcmfmac.ko firmware_path=/lib/firmware/brcm/brcmfmac43455-sdio.bin

       

      I also confirm that all related firmware is available in /lib/firmware/brcm/ folder.

       

      Attached is the config file for reference

      Sorry for long explanation.

      Thanks in Advance,

      Keshava Kumar