5 Replies Latest reply on Jun 24, 2020 9:48 PM by SampathS_11

    CY8C9520A INT not deactivated after reading Interrupt Status Port Register

    VlIl_4585586

      I configured the device to read and write pins on ports 0 and 1. Reading and writing pins works as expected.

      The interrupt mask for port 1 is set with 0 for pin 0 to enable Interrupt on port 1 pin 0. This pin is set as input and I can read it.

       

      When I start the device Interrupt output is inactive low. When I change the value of Port 1 pin 0, INT output goes active High. This is all as expected.

       

      The problem is that after INT is activated and I read register "Interrupt Status Port 1" the INT line does not go back to inactive low. I tried to read "Interrupt Status Port 1" repeatedly, and INT output is still not deactivated. There are no changes to any inputs after the initial change to Port 1, Pin 0. 

       

      Also, the value in "Interrupt Status Port 1" does not look right. According to the datasheet I expect to see 1 only for the pin that changed value. The value that I read is the same as the Input Port 1 value.

       

      To read "Interrupt Status Port 1" I write 0x10 to device address, and then read two bytes. I'm using logic analyser and looking at the data coming back from the device.

       

      I would appreciate any advice on this issue.