3 Replies Latest reply on Nov 20, 2019 4:59 AM by YashwantK_46

    USB FX3 bootloader fails on windows 10

    ArZa_1140216

      Hello

       

      Im using CyFwStorProg.exe to program my firmware to emmc. The process works fine on Win7 but on Windows 10 it seems that the process is completed successfully(see below log) but when rebooting the device keeps enumerating as cypress bootloader.

      I have installed the win10 x64 drivers supplied with sdk1.3.4.

       

      SUCCESS: Programmed Image "myimage.img" to Partition 0 in the Boot1 Location

      SUCCESS: Reset device(with PMode[2:0] set to 0) to boot programmed firmware

       

      FIN: Application Exiting.Press any key to continue . . .

       

       

      Any thoughts??

        • 1. Re: USB FX3 bootloader fails on windows 10
          YashwantK_46

          Hi,

           

          Can you please take wireshark traces for both the instance and share them?


          Also, can you please confirm that you are performing the exact same steps in both the versions of windows?

           

          Also, please check for the PMODE lines when you are trying to boot from the emmc.

           

          Regards,
          Yashwant

          • 2. Re: USB FX3 bootloader fails on windows 10
            ArZa_1140216

            Hi

            Thanks for our response.

            Unfortunately I cant get those traces right now..Any quick guide on ow to do so?

            We've been doing the process for over 2 years with our devices on windows7 with no issues.

            It seems o be something with win10.. Have you tried to program emmc with CyFwStorProg.exe on win10?

             

            Regards,

            Arie

            • 3. Re: USB FX3 bootloader fails on windows 10
              YashwantK_46

              Hey Arie,


              I tried programming a eMMC using CyFwStorProg.exe in win10 x64 laptop and i was able to see that the device was enumerating as it was supposed to when booting from the eMMC.


              Here's what i did to see this:

              1.) From usage example of CyFwStorProg.exe, i firstly used, cyfwstorprog.exe -vid:04B4 -pid:00F3 -delpart

                   A window will come up from file explorer asking to format the drive, please don't bother about it and let the .exe do its part.

              2.) I then used the command, cyfwstorprog.exe -vid:04B4 -pid:00F3 -img:test1.img

                   I didn't specify a boot partition and was able to successfully program the eMMC and got the debug messages like the ones that you mentioned.

              3.) Changed the boot mode to eMMC->USB fallback mode by changing it from "Z11" to "000".

              4.) Changed the connectots J21, J20, J25 and J26 from "SPI" to "SD CARD" and then "reset" the device.

              5.) The device enumerated as expected.


              Please do try the above method and share the findings with me.


              Regards,

              Yashwant