3 Replies Latest reply on Dec 19, 2019 1:15 AM by owrp_4560236

    How to configure raspberry pi 3b+ as a repeater in OpenWrt

    owrp_4560236

      Hi,

       

      I want to make a wireless-repeater with a RPI3B+.

       

      i could configure the RPI in client mode ( so the RPI connects to an AP), and also i succeeded to configure it as an AP bridged to the eth0.

      But when i tried to set-up the repeater configuration with 'relayd' , it didn't work at all.

       

      Error message :

      [  272.235971] ieee80211 phy0: brcmf_cfg80211_get_channel: chanspec failed (-52)

      [  272.436540] IPv6: ADDRCONF(NETDEV_UP): br-lan: link is not ready

      [  272.739925] IPv6: ADDRCONF(NETDEV_UP): wlan0-1: link is not ready

      [  272.752444] br-lan: port 1(wlan0-1) entered blocking state

      [  272.759074] br-lan: port 1(wlan0-1) entered disabled state

      [  272.765847] device wlan0-1 entered promiscuous mode

      [  272.772103] br-lan: port 1(wlan0-1) entered blocking state

      [  272.778665] br-lan: port 1(wlan0-1) entered forwarding state

      [  272.785677] IPv6: ADDRCONF(NETDEV_CHANGE): br-lan: link becomes ready

      [  272.900106] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready

      [  273.511367] br-lan: port 1(wlan0-1) entered disabled state

      [  276.024809] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready

      [  276.104586] ieee80211 phy0: brcmf_link_down: WLC_DISASSOC failed (-52)

      [  276.209243] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0-1: link becomes ready

      [  276.218177] br-lan: port 1(wlan0-1) entered blocking state

      [  276.225892] br-lan: port 1(wlan0-1) entered forwarding state

      [  277.031939] br-lan: port 1(wlan0-1) entered disabled state

      [  278.963718] br-lan: port 1(wlan0-1) entered blocking state

      [  278.971329] br-lan: port 1(wlan0-1) entered forwarding state

      [  287.191208] ieee80211 phy0: brcmf_escan_timeout: timer expired

      [  287.663918] br-lan: port 1(wlan0-1) entered disabled state

      [  287.876549] ieee80211 phy0: brcmf_link_down: WLC_DISASSOC failed (-52)

      [  287.981896] br-lan: port 1(wlan0-1) entered blocking state

      [  287.989454] br-lan: port 1(wlan0-1) entered forwarding state

      [  288.712223] br-lan: port 1(wlan0-1) entered disabled state

      [  291.097530] br-lan: port 1(wlan0-1) entered blocking state

      [  291.105016] br-lan: port 1(wlan0-1) entered forwarding state

      [  298.711210] ieee80211 phy0: brcmf_escan_timeout: timer expired

      [  299.182500] br-lan: port 1(wlan0-1) entered disabled state

      [  299.713574] ieee80211 phy0: brcmf_link_down: WLC_DISASSOC failed (-52)

      Regards.

        • 1. Re: How to configure raspberry pi 3b+ as a repeater in OpenWrt
          owrp_4560236

          Can any one tell me the meaning of these  :

           

          [  272.235971] ieee80211 phy0: brcmf_cfg80211_get_channel: chanspec failed (-52)

          [  276.104586] ieee80211 phy0: brcmf_link_down: WLC_DISASSOC failed (-52)

          • 2. Re: How to configure raspberry pi 3b+ as a repeater in OpenWrt
            VinayakS_26

            Hi,

             

            Are you using hostapd to setup the AP initially.

            If you using this relayd, could post the config used for that daemon.

             

            Regards,

            VinayakS_26

            • 3. Re: How to configure raspberry pi 3b+ as a repeater in OpenWrt
              owrp_4560236

              Hi,

               

              I'm using the command line uci to setup an AP. You can find below the continent of the configuration files:

               

              /etc/config/network:

               

              config interface 'loopback'

                  option ifname 'lo'

                  option proto 'static'

                  option ipaddr '127.0.0.1'

                  option netmask '255.0.0.0'

               

              config globals 'globals'

                  option ula_prefix 'fd61:7440:d7ac::/48'

               

              config interface 'lan'                                                         

                  option ifname 'eth0'                                                       

                  option type 'bridge'                                                       

                  option proto 'static'                                                      

                  option ip6assign '60'                                                      

                  option ipaddr '192.168.10.1'    # for relayd... requires 192.168.x.x address but not used by clients

                  option gateway '192.168.1.1'    # ip address of PrimaryAP                  

                  option netmask` '255.255.255.0'                                             

                  option dns '192.168.1.1'                                                   

                                                                                            

              config interface 'wwan'                                                        

                  option proto 'static'                                                      

                  option ipaddr '192.168.1.254'                                              

                  option netmask '255.255.255.0'                                             

                  option gateway '192.168.1.1'                                               

                                                                                             

              config interface 'stabridge'                                                   

                  option proto 'relay'                                                       

                  option network 'lan wwan'                                                  

                  option ipaddr '192.168.1.254'   # static ip assigned from PrimaryAP address range     

                                                                                            

               

               

              /etc/config/wireless:

               

              config wifi-device 'radio0'

                  option type 'mac80211'

                  option channel '11'

                  option hwmode '11g'

                  option path 'platform/soc/3f300000.mmcnr/mmc_host/mmc1/mmc1:0001/mmc1:0001:1'

                  option txpower '30'

               

              config wifi-iface 'default_radio0'

                  option device 'radio0'

                  option network 'lan'

                  option mode 'ap'

                  option ssid 'Repeater-AP'

                  option encryption 'psk2'

                  option key '*******'

               

              config wifi-iface                                                              

                  option device 'radio0'                                                     

                  option network 'wwan'                                                      

                  option encryption 'psk2'                                                   

                  option key '12345678'                                         

                  option mode 'sta'                                                          

                  option ssid 'Test'

               

               

              /etc/config/dhcp:

               

              config dnsmasq

                  option domainneeded '1'

                  option boguspriv '1'

                  option filterwin2k '0'

                  option localise_queries '1'

                  option rebind_protection '1'

                  option rebind_localhost '1'

                  option local '/lan/'

                  option domain 'lan'

                  option expandhosts '1'

                  option nonegcache '0'

                  option authoritative '1'

                  option readethers '1'

                  option leasefile '/tmp/dhcp.leases'

                  option resolvfile '/tmp/resolv.conf.auto'

                  option nonwildcard '1'

                  option localservice '1'

               

              config dhcp 'lan'

                  option interface 'lan'

                  option start '100'

                  option limit '150'

                  option leasetime '12h'

                  option ignore '1'

               

              config dhcp 'wan'

                  option interface 'wan'

                  option ignore '1'

               

              config odhcpd 'odhcpd'

                  option maindhcp '0'

                  option leasefile '/tmp/hosts/odhcpd'

                  option leasetrigger '/usr/sbin/odhcpd-update'

                  option loglevel '4'

               

               

               

              /etc/config/firewall:

               

              config defaults

                  option syn_flood    1

                  option input        ACCEPT

                  option output        ACCEPT

                  option forward        REJECT

               

               

              config zone

                  option name        lan

                  list   network        'lan wwan'

                  option input        ACCEPT

                  option output        ACCEPT

                  option forward        ACCEPT

               

              config zone

                  option name        wan

                  list   network        'wan'

                  list   network        'wan6'

                  option input        REJECT

                  option output        ACCEPT

                  option forward        REJECT

                  option masq        1

                  option mtu_fix        1

               

              config forwarding

                  option src        lan

                  option dest        wan

               

               

              Is there any thing wrong?