1 Reply Latest reply on Oct 30, 2019 7:54 AM by RakshithM_16

    Can't Uplink a program with Zerynth Studio on my PSoC6 Wifi-Bt Pioneer Kit

    DaTo_1851841

      I can’t uplink code to my kit. I had follow all the steps to register the kit, virtualize with two version of VM available,use degins spark account, use different versions of zerynth, try windows and linux, update kitprog to version 2, etc.

      The only answer i had possibly found was that my psoc 6 firmware ir out of date.
      As i saw in this blog:
      https://www.element14.com/community/roadTestReviews/3039#jive_content_id_Zerynth_Physical_Device_Detection_Issues

      They said that:
      *
      Zerynth will not work with this kit if its PSoC62 mcu has outdated firmware so make sure your kit doesnt show any outdated firmware warning in PSoC programmer.
      *

      And when I use modustoolbox to program my PSoC or read the binaries from PSoC Programmer i get the following message:

       

      *******************************************************************************

      * Your PSoC6 KIT is out of date. Please contact Cypress to get a replacement. *

      *******************************************************************************

       

      I look for the error on other community post, https://community.cypress.com/docs/DOC-16171, and it says:

       

      PSoC 6 MCU on some of the early PSoC 6 BLE Pioneer Kit (CY8CKIT-062-BLE) and PSoC 6 WiFi-BT Pioneer Kit (CY8CKIT-062-WiFiBT) has an older version of FlashBoot. Those development kits with the old version of FlashBoot are incompatible with the latest ModusToolbox™ IDE and may cause a programming failure.
      If you are using one those early development kits with ModusToolbox IDE, and you see the below message while programming the kit, it means that the FlashBoot on your kit is out of date.

       

      This is the only thing i can relate with this programming issue, that the FlashBoot its out of date because the version of my kit is an early one, cause i bought it two years ago.

       

      It would be really grateful if you guys can solve this!