6 Replies Latest reply on Oct 22, 2019 4:59 AM by LePo_1062026

    CY8CKIT-059 prototyping kit not detected in PSoC creater 4.2

    ArGe_4498221

      I have freshly installed PSoC Creater 4.2 and the corresponding kit design files. I started a blank new project with the kit selected. I plug in the debug USB port and the device remains undetected either using Tools->Find new devices ("No new devices are available") or under Tools->Bootloader Host (ports field completely blank).

      In device manager, the USB shows up as a USB Root Hub (3.0) and an Intel(R) USB 3.1 eXtensible Host Controller - 1.10 (Microsoft). The dev kit appears to be getting power, as the power led is blinking blue. I understand it should show up as a USB UART device of some sort. I

       

      I am using a Dell XPS 13 9370 and Microsoft Windows 10 64 bit Home. The Dell website says I have fully updated drivers. I am using a dell brand USB 3.0 to USB C converter because this laptop only has USB C ports.

       

      I would love to learn this tech and this is an annoying hurdle.

        • 1. Re: CY8CKIT-059 prototyping kit not detected in PSoC creater 4.2
          JoMe_264151

          Just to be totally correct:

          The CY8CKIT-059 has got a micro USB port which can be programmed and is not used for debugging.

          When running, close Creator. Restart your PC

          (I assume you) Did insert the kit directly (No cable!) into a free USB portof your computer.

          Start PSoC Programmer (Not Creator!)

          Click on the Kitprog interface which should be shown

          Check (Utilities) For updates and if there are program them into the kitprog.

          Clos programmer and remove the kit.

          Start Creator and insert the kit.

          Select Debug -> Select debug target. Do you see the kitprog and the PSoC5 (cy8c5888-I don't know the rest)

           

          When still not working, pleas tell which step did not work for you.

           

          Bob

          • 2. Re: CY8CKIT-059 prototyping kit not detected in PSoC creater 4.2
            LePo_1062026

            arge,

             

            I'm glad you have chosen the PSoC5 and I will try to help if I can.

             

            Try the followings steps:

            1. Make sure that the KitProg USB-UART driver is installed properly on your system.  To do this, open up Windows "Device Manager".  Look under the "Ports (COM &LPT)".  You should see an entry that says "KitProg USB-UART (COMxx)"  with 'xx' as the enumerated COM port..
            2. If 1. has a "KitProg USB-UART (COMxx)", then it is possible that:
              1. You have not created a new project with the target PSoC device which would be CY8C5888LTI-LP097.
              2. You have not loaded a CY8CKIT-059 example project (such as "Blinky LED").
                Without defining which PSoC Creator is going to build, the menu option "Debug\Select Debug Target..." will not show up.
            3. If 1. has no "KitProg USB-UART (COMxx)", you may need to reinstall the KitProg USB-UART driver.  Until this is accomplished, Creator cannot find the KitProg device to program the target device on the CY8CKIT-059 board.

             

            Let us know how the above suggestion work.

             

            Just as a couple of notes:

            "Tools->Find new devices" is intended on finding if new target devices are available from the Cypress website.  As new devices become available from Cypress, this is the means Creator has in making them available to the application.   This is not used to find the programming portal.  That is what "Debug\Select Debug Target..." is for.

             

            "Tools->Bootloader Host" is used to program the target PSoC if there is a bootloader already in the target.  In the case of the CY8CKIT-059 "out-of-the-box", the target has no bootloader therefore you will not need this utility to program the target.  If you're interested later on how to install a bootloader into the target, there are App notes and forum information to assist you.

             

            Hopefully this was helpful.

             

            Len

            • 3. Re: CY8CKIT-059 prototyping kit not detected in PSoC creater 4.2
              ArGe_4498221

              I have installed the drivers at this link: https://www.cypress.com/documentation/software-and-drivers/microsoft-certified-usb-uart-driver

              I have reinstalled (twice) the PSoC Programmer (not the Cypress Programmer) at this link: https://www.cypress.com/products/psoc-programming-solutions

               

              I have attempted to install these devices on another computer running Windows 8 with no USB hub getting in the way, to the same result. For now, lets focus on getting it to work on the XPS13 I described in the original post.

               

              @Bob,

              The procedure after starting PSoC Programmer. The device does not show up at all when plugged in.

              There is no prompt for updating the PSoC Programmer, and it appears to be up to date. All buttons for updating firmware etc. are greyed out. Here is the 'about' page for PSoC Programmer:

              Furthermore, in PSoC Creator, the Debug menu is greyed out (no doubt because no device was detected at all)

               

              @Len,

               

              Signs seem to point to the USB drivers not being installed. Here is a screenshot of my device manager with the device plugged in via USB:

               

              No devices connected at all via Ports so the tab does not even show up. Plugging in the device causes it to show up as a USB device among those other USB devices. Again, I have installed the drivers listed above.

              I have attempted this on another computer so I must be missing a step in the procedure. So far, the answers I have gotten work under the presumption that the correct USB drivers are installed when installing PSoC Programmer, which I have reinstalled twice and installed twice on another computer to no avail. The PSoC programmer supports version 5LP so it is the correct version.

              • 4. Re: CY8CKIT-059 prototyping kit not detected in PSoC creater 4.2
                ArGe_4498221

                Furthermore, the KitProg user guide (at https://www.cypress.com/file/157966/download) says the following:

                 

                At no point in installation of the PSoC programmer, PSoC creator or plugging in the device while any or none of these are open does such a "Driver Software Installation" dialogue pop up.

                • 5. Re: CY8CKIT-059 prototyping kit not detected in PSoC creater 4.2
                  GeonaP_26

                  Please manually point to the KitProg.inf file available in PSoC Programmer installation directory (C:\Program Files (x86)\Cypress\Programmer\drivers\KitProg\KitProg.inf). The steps are elaborated here: https://www.cypress.com/comment/263056 

                  • 6. Re: CY8CKIT-059 prototyping kit not detected in PSoC creater 4.2
                    LePo_1062026

                    ArGe,

                     

                    You show a Device Manager Window but I would assume the window was taken WITHOUT the KitProg plugged in.

                    Please try Device Manager with the KitProg board plugged in.

                    If the install is successful, you should see a category show up as "Ports (COM & LPT)".  If not, you should see another catergory displayed as "Other devices" and a new device under this category is listed as "Unknown device".  

                    If this is the case, select "Unknown device" and right-click to get to "Properties".

                    Once the Properties window comes up, select the "Details" tab.  Then you should see a Property down-down.  Drop-down to find "Hardware Ids".  You show get a window similar to that shown below.   Please report the information in the "Value" window.

                    Len