2 Replies Latest reply on Oct 12, 2019 12:34 AM by RaAr_1021711

    problem faced with cypress CYUSB3014-BZXI

    RaAr_1021711

      We are facing USB boot problem with above device. We have 4 Cyusb3014 on our PCB with only 2 detected by PC. other two was not detected at all.

       

      We are giving clock 19.2 Mhz SQUARE WAVE FROM FPGA, ALL POWER SUPPLY ARE SELF GENERATED. VBATT IS OPEN. VBUS IS COMING FROM USB CONNECTOR.All four device are having same circuit.

       

      To debug the problem we populated one more pcb and soldered one CYUSB3014 on location where it was working fine on pcb 1. But it was now not detecting on PCB 2.

       

      When reset input is low it is drawing 2 mA current from 1.2 V SUPPLY and when reset is high it is drawing only 8 mA current.

       

      We are giving 100 ms reset pulse at power on.

       

      The data code of device is 1207 and revision is A 33. We don't have any EEPROM on our board to test any other boot mode.

       

      Can it be device lot issue?

       

      We have followed AN70707.

        • 1. Re: problem faced with cypress CYUSB3014-BZXI
          HemanthR_06

          Hi,

           

          - When you populated PCB2 (in the same slot as of PCB1 where the device was working), did you populate with one of the ICs on PCB1?

          - Can you try swapping working and non-working ICs on PCB1? (To check if the issue is following the silicon)

          - Howmany boards have you tested? And howmany show the issue?

          - Is there a board where all the 4 ICs work?

           

          Regards,

          Hemanth

          • 2. Re: problem faced with cypress CYUSB3014-BZXI
            RaAr_1021711

            Hello,

            Thanks for the reply

            When you populated PCB2 (in the same slot as of PCB1 where the device was working), did you populate with one of the ICs on PCB1?

             

            answer> No, we have used new device.

             

            Can you try swapping working and non-working ICs on PCB1? (To check if the issue is following the silicon)

            answer> will try that and update

             

            - Howmany boards have you tested? And howmany show the issue?

            Answer> We have tested two boards and both have issues

             

            - Is there a board where all the 4 ICs work?

            Answer> no

             

            One more observation:

            When reset input is low it is drawing 2 mA current from 1.2 V SUPPLY and when reset is high it is drawing only 8 mA current.

             

            Current is always 8 mA, it did not change when i change clock to 38.4 and keep FSCL lines for 19.2 MHz. Giving clock or not has no change in device current on VDD lines

             

            Regards

             

            rajat