1 2 Previous Next 20 Replies Latest reply on Nov 8, 2019 7:10 AM by MaPf_1293106

    Debug mode keeps failing/disconnecting

    KeSn_4175816

      About 85% of the time after the device outputs  "...successfully programmed at..."  I receive 2 errors  (see below). I get these errors on multiple devices (PSoC 4200L and  PSoC 4200M). This happens even when I use example code from Cypress.

       

      Currently I am using PSoC Creator 4.2 on windows 7 and encounter the problem in multiple example projects/codes such as I2C_SCB_Master, I2C_SCB_Slave, Breathing_LED, etc.

       

      The debug select in the system tab of the  .CYDWR file is set to SWD (serial wire debug).

      I've used example code from cypress, and made sure only one device is plugged in at a time.

      I'm not using sleep or deep sleep modes

      I've tried different USB cables, and different USB ports.

      To my knowledge PSoC creator is whitelisted on AV software (also not getting any red flags in AV software) and disabling AV software is not an option .

       

      The only solution I have found thus far is to unplug the device wait a second and re-plug in the device, and then I usually have to select the target and click port acquire multiple times in order to acquire the target and connect.

       

      The errors:

      PSoC Creator Error dbg.M0007

      The run request failed. Encountered error (Invalid thread id: 1)

      The request to run the application on the target failed. Make sure that your code is valid and that the selected target supports debugging.

       

      PSoC Creator Error dbg.M0015

      Debugger exited unexpectedly during run. Encountered error (Remote communication error. Target disconnected.: No error.)

      There was an unhanded error during the debug session. This has forced the debugger to shutdown. Try again.

       

      Unless there is some sort of register I need to clear, I'm out of ideas and searching for the errors hasn't proved fruitful.

      Can anyone point me in the right direction for dealing with these errors?

       

      Thanks in advance

        1 2 Previous Next