6 Replies Latest reply on Oct 17, 2019 2:49 AM by SheetalJ_96

    Headset App on CYBT-353027-EVAL

    IvDe_4459626

      I'm trying to run the Headset app on the CYBT-353027-EVAL board. So far I can't get it to work.

      I've followed the instruction to create a CYBT-353027-EVAL build target, and I copied FM25Q04_sflash.a. After I load the application, nothing happens. In order to re-flash, I need to go through the recovery procedure and use the command-line tool ChipLoad.exe. I also tried with the original FM25Q04-sflash.a that came with Wided Studio 6.4

      I tried enabling debug output on puart and there was no activity.

       

      To validate my setup, I built the hello_sensor BLE app. This one works well, I can discover the device and browse GATT. Puart debug output works well when enabled. I can load an app from Wiced studio without habing to use the ChipLoad.exe tool. So I believe my build environment is set up properly.

       

      Is the headset app not supported for th CYBT-353027-EVAL ?

       

      Is there any way to set up debugging on this eval board?

       

      Thanks!

        • 1. Re: Headset App on CYBT-353027-EVAL
          SheetalJ_96

          Hello IvDe_4459626,

           

          Please check if you have enabled STANDALONE_HEADSET_APP flag in Makefile. CYBT-353027 supports headset app; I have tested the headset app on CYBT-343026 module in WICED 6.2.1, it works fine.

          Let me know if you still face the issue.

          • 2. Re: Headset App on CYBT-353027-EVAL
            IvDe_4459626

            Hello ! and thank you for your suggestion.

             

            I checked the makefile and STANDALONE_HEADSET_APP was commented out. I enabled the option. The result is unfortunately the same. The board becomes unresponsive. No output on puart. No device discoverable through a bluetooth scanner. Need to go through the recovery procedure to be able to re-program the board.

             

            Do you know of any document that would explain the STANDALONE_HEADSET_APP flag or any other flags/settings that need to be checked?

             

            Thanks!

            • 3. Re: Headset App on CYBT-353027-EVAL
              SheetalJ_96

              Uncomment the C_FLAGS += -DSTANDALONE_HEADSET_APP flag in makefile.mk. Program the board from WICED SDK using Make Target:  demo.audio.headset-CYBT_343026_EVAL download UART=COM39 (mention the board you are using)

               

              Open ClientControl, select HCI COM port, Baudrate as 3M and click on Open port. Now, you should see device advertising itself. ClientControl options will get enabled. Connect the device to your mobile phone and check different functionalities in AVRC CT tab in ClientControl. You should be able to hear audio in headphones/earphones connected to 20706 device which is playing in your mobile. You need to connect a codec to CYW20706 device in order to listen the audio. The app should work best with iOS device (iPhone).

              1 of 1 people found this helpful
              • 4. Re: Headset App on CYBT-353027-EVAL
                IvDe_4459626

                Hello SheetalJ_96!

                 

                Thank you for your suggestions, your help is sincerely appreciated.

                 

                I tried building both targets: CYBT_343026_EVAL and CYBT_353027_EVAL. Neither seem to work with the Client Control app: the serial port is open, but options/buttons don't become available. I tried with/without flow control.

                 

                The only way to reprogram the board is to follow Programming an EZ-BT WICED Module – KBA223428  and to "Program with Recovery Procedure", that is using ChipLoad.exe and -NODLMINIDRIVER, etc.

                 

                I have a codec ready to connect to the 353027_EVAL board, but I wanted the board to become discoverable and pair to it first.

                 

                Could this be a 353027-specific problem?

                 

                 

                Regards,

                Ivan

                • 5. Re: Headset App on CYBT-353027-EVAL
                  SheetalJ_96

                  Hi Ivan,

                   

                  Can you try setting the baurate at 115200 and see if it works?

                  • 6. Re: Headset App on CYBT-353027-EVAL
                    SheetalJ_96

                    Can you try using iOS device? I was able to see the Headset with CYBT-353027 in iPhone but not in Android phone, set the Baudrate at 3M, Flow Control ON. Reset the device after Opening the port in ClientControl if options don't get enabled.

                    1 of 1 people found this helpful