1 Reply Latest reply on Oct 2, 2019 10:57 PM by HirotakaT_91

    FX3 SPI ROM

    maha_3075721

      Im masa,

       

      I connected S25FS064 (S25FS064SAGNFM030) to the FX3 SPI

      We are developing a board.

       

      https://community.cypress.com/docs/DOC-14504

      Because S25FS064 was recommended for the compatible ROM listed.

       

      However, there was a problem when writing with ”USB Control Center Utility SPI FLASH”.

       

      When I looked into it, I understood that ROM could not be erased.

       

      For confirmation.

      When  installed the UsbSpiDmaMode program in FX3 RAM. CY_FX_RQT_SPI_FLASH_ERASE_POLL is worked.

      The hardware seems correct.

       

      How can I make the USB Control Center Utility SPI FLASH work properly?

        • 1. Re: FX3 SPI ROM
          HirotakaT_91

          Hello,

           

          Thank you for using Cypress Developer Community.

          Let me clarify the situation.

           

          - Are you sure the PMODE setting is USB boot (F11) when you do programming FW? Moreover, PMODE setting is SPI (0F1) when starting its FW?

          - Have you tried CyBootProgrammer.img (located in "C:\Program Files (x86)\Cypress\EZ-USB FX3 SDK\1.3\bin") for test? Is it lead same result?

          - Is hardware connection on your board between SPI Flash and FX3 similar to CYUSB3KIT-003 hardware?

          - How did you check CY_FX_RQT_SPI_FLASH_ERASE_POLL is working without any issue? Did you check the return status of CyFxSpiEraseSector() API is CY_U3P_SUCCESS?

           

          Best regards,

          Hirotaka Takayama