3 Replies Latest reply on Sep 16, 2019 1:23 AM by DheerajK_81

    Missing builders for CYBL-416045-02?

    EdHa_4455331

      I loaded up the BLE "Find Me" code example for the CYBL-416045-02 into Modus from the Git Repository.

       

      But the projected did not include any Builders. Most other projects seem to include CDT Builder and Scan Configuration Builder.

      I would add these manually, but the build diaglog doesn't seem to know anything about them and I don't know where to import

      them from. So the project won't build.

       

      Andy suggestions?

        • 1. Re: Missing builders for CYBL-416045-02?
          DheerajK_81

          Please follow this KBA to import projects correctly: Importing Code Example into ModusToolbox IDE - KBA225201

           

          Regards,

          Dheeraj

          • 2. Re: Missing builders for CYBL-416045-02?
            EdHa_4455331

            Thank you for your prompt response. I THOUGHT that was how I did it. But I erased everything and tried again, and this time the build operation was in place. BUT…

            Now I am getting errors related to the LED ports (see below) . It looks like there is a define of a define in LED.H, but the base level define cannot be found. I tried to be clever and work around this myself. I figured I could see how it was done in the Blinky project, and then use that info to repair the FindMe project. But the blinky project throws similar errors, too.

             

            Any suggestions?

             

            Thanks,

             

            Ed H.

             

            In file included from ../Source/debug.h:24:0,

                             from ../Source/debug.c:17:

            ../Source/debug.c: In function 'ShowError':

            ../Source/LED.h:34:32: error: 'KIT_RGB_G_PORT' undeclared (first use in this function)

              #define Advertising_LED_PORT  KIT_RGB_G_PORT

                                            ^

            ../Source/debug.c:29:19: note: in expansion of macro 'Advertising_LED_PORT'

                 Cy_GPIO_Write(Advertising_LED_PORT, Advertising_LED_PIN, LED_ON);

                               ^~~~~~~~~~~~~~~~~~~~

            ../Source/LED.h:34:32: note: each undeclared identifier is reported only once for each function it appears in

              #define Advertising_LED_PORT  KIT_RGB_G_PORT

                                            ^

            ../Source/debug.c:29:19: note: in expansion of macro 'Advertising_LED_PORT'

                 Cy_GPIO_Write(Advertising_LED_PORT, Advertising_LED_PIN, LED_ON);

                               ^~~~~~~~~~~~~~~~~~~~

            ../Source/LED.h:38:32: error: 'KIT_RGB_G_PIN' undeclared (first use in this function); did you mean 'KIT_RGB_G_PORT'?

              #define Advertising_LED_PIN   KIT_RGB_G_PIN

                                            ^

            ../Source/debug.c:29:41: note: in expansion of macro 'Advertising_LED_PIN'

                 Cy_GPIO_Write(Advertising_LED_PORT, Advertising_LED_PIN, LED_ON);

                                                     ^~~~~~~~~~~~~~~~~~~

            ../Source/LED.h:33:28: error: 'KIT_RGB_B_PORT' undeclared (first use in this function); did you mean 'KIT_RGB_G_PORT'?

              #define Alert_LED_PORT    KIT_RGB_B_PORT

                                        ^

            ../Source/debug.c:30:19: note: in expansion of macro 'Alert_LED_PORT'

                 Cy_GPIO_Write(Alert_LED_PORT, Alert_LED_PIN, LED_ON);

                               ^~~~~~~~~~~~~~

            ../Source/LED.h:37:27: error: 'KIT_RGB_B_PIN' undeclared (first use in this function); did you mean 'KIT_RGB_G_PIN'?

              #define Alert_LED_PIN    KIT_RGB_B_PIN

                                       ^

            ../Source/debug.c:30:35: note: in expansion of macro 'Alert_LED_PIN'

                 Cy_GPIO_Write(Alert_LED_PORT, Alert_LED_PIN, LED_ON);

                                               ^~~~~~~~~~~~~

            ../Source/LED.h:35:32: error: 'KIT_RGB_R_PORT' undeclared (first use in this function); did you mean 'KIT_RGB_B_PORT'?

              #define Disconnect_LED_PORT   KIT_RGB_R_PORT

                                            ^

            ../Source/debug.c:31:19: note: in expansion of macro 'Disconnect_LED_PORT'

                 Cy_GPIO_Write(Disconnect_LED_PORT, Disconnect_LED_PIN, LED_ON);

                               ^~~~~~~~~~~~~~~~~~~

            ../Source/LED.h:39:31: error: 'KIT_RGB_R_PIN' undeclared (first use in this function); did you mean 'KIT_RGB_B_PIN'?

              #define Disconnect_LED_PIN   KIT_RGB_R_PIN

                                           ^

            ../Source/debug.c:31:40: note: in expansion of macro 'Disconnect_LED_PIN'

                 Cy_GPIO_Write(Disconnect_LED_PORT, Disconnect_LED_PIN, LED_ON);

                                                    ^~~~~~~~~~~~~~~~~~

            make: ***  Error 1

            make: *** Waiting for unfinished jobs....

            In file included from ../Source/debug.h:24:0,

                             from ../Source/BLEFindMe.h:24,

                             from ../Source/BLEFindMe.c:16:

            ../Source/BLEFindMe.c: In function 'MCWDT_Interrupt_Handler':

            ../Source/LED.h:33:28: error: 'KIT_RGB_B_PORT' undeclared (first use in this function)

              #define Alert_LED_PORT    KIT_RGB_B_PORT

                                        ^

            ../Source/BLEFindMe.c:75:21: note: in expansion of macro 'Alert_LED_PORT'

                     Cy_GPIO_Inv(Alert_LED_PORT, Alert_LED_PIN);

                                 ^~~~~~~~~~~~~~

            ../Source/LED.h:33:28: note: each undeclared identifier is reported only once for each function it appears in

              #define Alert_LED_PORT    KIT_RGB_B_PORT

                                        ^

            ../Source/BLEFindMe.c:75:21: note: in expansion of macro 'Alert_LED_PORT'

                     Cy_GPIO_Inv(Alert_LED_PORT, Alert_LED_PIN);

                                 ^~~~~~~~~~~~~~

            ../Source/LED.h:37:27: error: 'KIT_RGB_B_PIN' undeclared (first use in this function); did you mean 'KIT_RGB_B_PORT'?

              #define Alert_LED_PIN    KIT_RGB_B_PIN

                                       ^

            ../Source/BLEFindMe.c:75:37: note: in expansion of macro 'Alert_LED_PIN'

                     Cy_GPIO_Inv(Alert_LED_PORT, Alert_LED_PIN);

                                                 ^~~~~~~~~~~~~

            ../Source/BLEFindMe.c: In function 'BleFindMe_Process':

            ../Source/LED.h:33:28: error: 'KIT_RGB_B_PORT' undeclared (first use in this function)

              #define Alert_LED_PORT    KIT_RGB_B_PORT

                                        ^

            ../Source/BLEFindMe.c:220:27: note: in expansion of macro 'Alert_LED_PORT'

                         Cy_GPIO_Write(Alert_LED_PORT, Alert_LED_PIN, LED_OFF);

                                       ^~~~~~~~~~~~~~

            ../Source/LED.h:37:27: error: 'KIT_RGB_B_PIN' undeclared (first use in this function); did you mean 'KIT_RGB_B_PORT'?

              #define Alert_LED_PIN    KIT_RGB_B_PIN

                                       ^

            ../Source/BLEFindMe.c:220:43: note: in expansion of macro 'Alert_LED_PIN'

                         Cy_GPIO_Write(Alert_LED_PORT, Alert_LED_PIN, LED_OFF);

                                                       ^~~~~~~~~~~~~

            ../Source/BLEFindMe.c: In function 'StackEventHandler':

            ../Source/LED.h:34:32: error: 'KIT_RGB_G_PORT' undeclared (first use in this function)

              #define Advertising_LED_PORT  KIT_RGB_G_PORT

                                            ^

            ../Source/BLEFindMe.c:286:31: note: in expansion of macro 'Advertising_LED_PORT'

                             Cy_GPIO_Write(Advertising_LED_PORT, Advertising_LED_PIN, LED_ON);

                                           ^~~~~~~~~~~~~~~~~~~~

            ../Source/LED.h:38:32: error: 'KIT_RGB_G_PIN' undeclared (first use in this function); did you mean 'KIT_RGB_G_PORT'?

              #define Advertising_LED_PIN   KIT_RGB_G_PIN

                                            ^

            ../Source/BLEFindMe.c:286:53: note: in expansion of macro 'Advertising_LED_PIN'

                             Cy_GPIO_Write(Advertising_LED_PORT, Advertising_LED_PIN, LED_ON);

                                                                 ^~~~~~~~~~~~~~~~~~~

            ../Source/LED.h:35:32: error: 'KIT_RGB_R_PORT' undeclared (first use in this function); did you mean 'KIT_RGB_G_PORT'?

              #define Disconnect_LED_PORT   KIT_RGB_R_PORT

                                            ^

            ../Source/BLEFindMe.c:287:31: note: in expansion of macro 'Disconnect_LED_PORT'

                             Cy_GPIO_Write(Disconnect_LED_PORT, Disconnect_LED_PIN, LED_OFF);

                                           ^~~~~~~~~~~~~~~~~~~

            ../Source/LED.h:39:31: error: 'KIT_RGB_R_PIN' undeclared (first use in this function); did you mean 'KIT_RGB_G_PIN'?

              #define Disconnect_LED_PIN   KIT_RGB_R_PIN

                                           ^

            ../Source/BLEFindMe.c:287:52: note: in expansion of macro 'Disconnect_LED_PIN'

                             Cy_GPIO_Write(Disconnect_LED_PORT, Disconnect_LED_PIN, LED_OFF);

            • 3. Re: Missing builders for CYBL-416045-02?
              DheerajK_81

              The Find Me code example was implemented for PSoC 6 BLE Pioneer Kit. You will need to make changes for it work on the PSoC 6 BLE Prototyping Kit. For example, the code example uses RGB LEDs for BLE connection status indication. You need to use the red and green led on the kit instead.

               

              I have made all the changes and attached it for your reference. Let me know if it works.

               

              Regards,

              Dheeraj

              1 of 1 people found this helpful