1 Reply Latest reply on Sep 10, 2019 10:24 PM by SheetalJ_96

    IOS 13 beta HFP disconnect

    VaPa_4086226

      Problem Overview:

      We are trying to pair with IOS-13 beta and we support (HFP,A2DP,GATT,ANCS). So first Connect LE(GATT and ANCS) then Connect HFP but after sometime the HFP disconnects.

      The Reason for the disconnection :

       

      RCVD [0] Event from HCI.  Name: HCI_Disconnection_Complete   (Hex Code: 0x05  Param Len: 4)

      Status : Success (0x00)

      Connection Handle : 13 (0x000d)

      Reason : 8 (0x08)

      Connection Timeout

       

      Observation1 : Based on the Attachment “bluetoothd-hci-latest_A2dp”

      I see there was no response to the “AVDTP Discover” and there was disconnection which I think was initiated from the IOS-13. Please find the attachment and it also has IOS phone sniffer logs.

       

      Observation2 : Based on Attachment “Handsfree_Disconnect_WithoutA2dp_IOS”

      I disabled the A2DP  from my code and re run the program but still there was a disconnection and there was same error  but I think it was because, phone was not responding to AT+VGS and AT+VGM with Ok.

      The log “Handsfree_Disconnect_WithoutA2dp_IOS”(Phone Log) and handsfree_disconnect_without_A2dp(Cypress log).

      Note : We have also tried not to send AT+VGS after SLC connection but the behavior was still same.

       

      Observation 3:  Based on Attachment “handsfree_disconnect_3_withoutANCS”

      I tried disabling the ANCS profile but still the disconnect was observed with same error.

       

       

       

      Could you please help us to resolve this issues.

      Note : “bluetoothd-hci-latest_a2dp.pklg” this is IOS log which can be opened in any MAC OS with PACKET logger.