13 Replies Latest reply on Aug 30, 2019 4:58 AM by BeCa_4374986

    CYW43340: FCC Wi-Fi test. wl tool. Return 'wl: Unsupported'

    BeCa_4374986

      Hello.

       

      We are trying to prepare Wi-Fi software test for the reference lab to certificate our device.

      Our Communication Module uses a CYW43340 Cypress Module.

      We have 'wl' tool already installed and operative at our test device.

      Apparently wl is working and we can manage to execute up-down the interface, check status, version, and other basic commands.

       

      We are having problems on executing more specific Wi-Fi test commands which are returning the message: 'wl: Unsupported'.

      When this happens the command is not taking effect on the device Wi-Fi Status.

       

      For example below commands are returning 'wl: Unsupported' and in the spectrum analyzer we cannot find tx signal from device:

      • wl pkteng_start fc:db:b3:7f:5a:e3 tx 20 1500 0
      • wl pktengs_stats
      • wl pkteng_stop tx

      The same with more commands.

       

      Our installed Driver-Firmware Version are:

       

      Reading other discussions in this Community we guess that we should not have the correct Firmware installed in the device to develop this Wi-Fi test.

      Should we need to install different driver and/or firmware? If yes, How could we get it?

      Any missed information please let me know.

       

      Thanks for support.

        • 1. Re: CYW43340: FCC Wi-Fi test. wl tool. Return 'wl: Unsupported'
          ShawnA_01

          Yes, it's imperative the version of WL Tool matches the version of firmware running down in the radio.  Make sure you use both from the same software release package. 

           

          For example, from the same WICED STUDIO Release, e.g. WICED STUDIO 6.4 found here - WICED Studio Wi-Fi/Combo Docs & Downloads.  Or from the same Linux release, e.g. 'Varan' found here - Cypress Linux FMAC (Varan).

           

          When using a WiFi solution from one of our "module partners", you should use their offering first.

          2 of 2 people found this helpful
          • 2. Re: CYW43340: FCC Wi-Fi test. wl tool. Return 'wl: Unsupported'
            BeCa_4374986

            Hello ShawnA_01.

             

            In this previous discussion: https://community.cypress.com/thread/47929 , we asked for the specific WL tool for our device specifications. MuraliR_36 attached us the wl_x86 tool that we are using.

            I realize that we now need the Firmware that matches with this 'wl_x86'.

             

            How could we obtain this specific Firmware? May you provide us some download link, attached it to us or indicate to us how proceed?

             

            Thanks for your support.

            • 3. Re: CYW43340: FCC Wi-Fi test. wl tool. Return 'wl: Unsupported'
              ShawnA_01

              Hi Benjamin - I wasn't aware of your previous history whereby MuraliR_36 from Cypress had given a version of WL Tool to run on your platform.  WL tool doesn't have defensive provisions in place to know if it's compatible, or incompatible with the flavor of Radio FW running. I have no way to ascertain what Radio FW the version Murali provided works with.  This is one reason why we recommend you work with the module partner for the design collateral.  At one point I think I saw a comment you're using a Cypress module?   Which one, or was that statement in error and in fact you're just using a Cypress WiFi device instead?

               

              To summarize:

              a) Get the design collateral from the module partner, as they can give compatible WL Tool executable for the Radio FW in use.  (As a VAR partner, the module partners have access to WL Source code and are tasked with compiling if for the various Linux hosts/kernel versions).

               

              or,

               

              b) We ask Murali to give the Radio FW that's compatible with the WL tool provided earlier.  This is a dangerous approach if the (new) FW is not a sanctioned (aka Cypress SVT validated official) release.

               

              Please comment - MuraliR_36

              2 of 2 people found this helpful
              • 4. Re: CYW43340: FCC Wi-Fi test. wl tool. Return 'wl: Unsupported'
                MuraliR_36

                Hi BeCa_4374986

                 

                As ShawnA_01 mentioned, you could try to get the compatible WL tool from the module partners.

                Further, could you let us know which firmware you are using, is it the mfgtest firmware?

                 

                Thanks,

                Murali

                1 of 1 people found this helpful
                • 5. Re: CYW43340: FCC Wi-Fi test. wl tool. Return 'wl: Unsupported'
                  BeCa_4374986

                  Hi.

                   

                  I am not sure of the correct denomination of the installed Firmware: BCM43341 or bcmdhd.

                  This is the result of listing /etc/firmware/:

                   

                  More details of Driver and Firmware installed. Executing: $ cat /sys/module/bcm4334x/parameters/info_string

                   

                  WL tool (wl_x86) that you attached us in the previous Discussion looks like working properly for executing general command as change the country, change band, change channel, and others basic configurations for Wi-Fi.

                  Problems are is coming when we try specific Wi-Fi test commands as: 'wl pkteng_start 00:11:22:33:44:55 tx 20 1500 0' that is having no effect and return: 'wl: Unsupported'.

                  We guess that we are not using 'mfgtest firmware'. May it be the problem? May we obtained it?

                  • 6. Re: CYW43340: FCC Wi-Fi test. wl tool. Return 'wl: Unsupported'
                    ShawnA_01

                    Yes, you need to be using the manufacturing test firmware to run specialized commands during certifications testing. 

                     

                    Note:  I know you're not using WICED, but I see the latest WICED STUDIO SDK - Version 6.4.0.61 provided (manufacturing test) CYW43340 Radio FW Version 6.49.29.  When I look at the latest CYW43340 Linux release firmware (from the 'Varan' release), I see (manufacturing test)  CYW43340 Radio FW Version is 6.10.190.77

                     

                     

                    Where did you get the Version 6.20.190.3 firmware from?

                    2 of 2 people found this helpful
                    • 7. Re: CYW43340: FCC Wi-Fi test. wl tool. Return 'wl: Unsupported'
                      BeCa_4374986

                      Hi ShawnA_01.

                      1. WICED:
                        • Right. I am not using WICED.
                        • I try to create the sripts for the reference laboratory we work with so that they can perform the emision tests for obtaining FCC-CE SAR Certification.
                        • We have already create scripts for Bluetooth test with the open source tool: 'hcitool' and some guide of commands and tables that Murata provided us.
                        • Now with the WL tool compatible with our device (which your colleague provided us and is working well on the device for standards commands) and a compatible 'Manufacturing FW' (that would let to 'WL' to execute the specific test commands), I think that we should prepare similar scripts for testing Wi-Fi emisions.

                       

                      2) Where did you get the Version 6.20.190.3 firmware from?

                      • This device has a Yocto OS running. Device and Yocto OS has been developed/configured for a team that is not working with us anymore. I am sorry but I cannot get to know where they got the FW Version from
                      • The device is using an Intel-Edison Module. I guess that maybe is the standard production FW avaible in Intel-Edison Module Driver-Firmware package but I am not sure about.

                       

                      For preparing Wi-Fi test we are reviewing the 'Cypress Wi-Fi CLM Regulatory Manual', in page 37 we find out  a scheme that indicate steps for a standard certification process for a Wi-Fi Device. We cannot execute the steps 2 ( wl commands for 'verifying radio power using'). Now I guess that we need the 'Manufacturing FW' compatible with the WL Tool for executing this and other specific commands.

                       

                      With all this I guess that our neccesity is to obtain the Manufacturing FW compatible for the WL tool that MuraliR_36 has already provided us.

                       

                      If you need some more info from us that I can bring please let me know.

                      We need to advance in this test as soon as possible. Laboratory resources are waiting for us to send some test software to work with.

                       

                      Thanks for your support.

                      • 8. Re: CYW43340: FCC Wi-Fi test. wl tool. Return 'wl: Unsupported'
                        MuraliR_36

                        Hi BeCa_4374986

                         

                        I have attached the mfgtest firmware compatible with the wl tool i had provided.

                        The commands with which you faced the issues should work now.

                        Do let us know if you face any more issues.

                         

                        Thanks

                        Murali

                        1 of 1 people found this helpful
                        • 9. Re: CYW43340: FCC Wi-Fi test. wl tool. Return 'wl: Unsupported'
                          BeCa_4374986

                          Hi MuraliR_36.

                          Thanks for this firmware.

                           

                          I have downloaded this firmware that you attached me to the device on:

                                    $ ls /etc/firmware/

                                         LICENCE.broadcom_bcm43xx  bcm43341.conf  bcm43341.hcd  bcmdhd.cal  bcmdhd_aob.cal  brcmfmac43340-sdio.bin  fw_bcmdhd.bin

                           

                          I have modificated the reference path from driver to find out the new firmware:

                               $ cat /etc/modprobe.d/bcm4334x.conf

                                    options bcm4334x firmware_path=/etc/firmware/brcmfmac43340-sdio.bin nvram_path=/etc/firmware/bcmdhd.cal op_mode=4

                           

                          For the moment still I cannot work with wl tool and this firmware.

                          I guess that I am doing something wrong with the firmware installation on the device.

                          If you see something clearly wrong that I have done please let me know.

                          Otherwise let me do some more test before confirming you if it WL is working or not with this new firmware.

                          • 10. Re: CYW43340: FCC Wi-Fi test. wl tool. Return 'wl: Unsupported'
                            MuraliR_36

                            Hi BeCa_4374986

                             

                            By "For the moment still I cannot work with wl tool and this firmware"

                            do you mean that none of the wl commands are working?

                            or

                            do you mean that the basic wl commands are working and the commands which didn't work before are still not working?

                             

                            And regarding what the issue,looks like we have to dig into it and figure out whats wrong.

                             

                            Thanks,

                            Murali

                            1 of 1 people found this helpful
                            • 11. Re: CYW43340: FCC Wi-Fi test. wl tool. Return 'wl: Unsupported'
                              BeCa_4374986

                              Hi MuraliR_36.

                               

                              Sorry about my delay on answering.

                              I have repeated and documented the steps and results that I have obtained so that I can bring better details of the situation.

                              I have insert the firmware that you attached me and try WL tool commands. Some commands that before was not working looks like working but still I cannot execute wl pkteng_start command.

                               

                              Below I show a secuence for:

                              1. Situation of Firmware/driver originally.
                              2. WL commands working.
                              3. Examples of WL commands not working.
                              4. To recieve compatible with wlx86 Manufacturing FW from Cypress.
                              5. To install received Firmware.
                              6. Reboot Device.
                              7. Try wl Commands.

                               

                              After below showed process I don't find out the where the problem is:

                              1. Maybe I am not executing well command wl pkteng_start.
                              2. Maybe I did not install Firmware correctly? Should I need some additional driver or nvram file?
                              3. Different reasons that you may see clearly than me.

                               

                              --------------------------------------------------------------------------------------------------SECUENCE----------------------------------------------------------------------------------------------------

                               

                              1.) Situation of Firmware/driver originally:

                              • List original firmware directory:

                                             $ ls etc/firmware/

                              • If we see content of ‘bcm43341.conf’ we find out FW patch path:

                                   # FW patch file
                                   fw_patch = /etc/firmware/bcm43341.hcd

                               

                              • Path of Firmware and Nvram:

                                             $ cat etc/modprobe.d/bcm4334x.conf

                                  

                              • Driver-Firmware version:

                                              $ cat /sys/module/bcm4334x/parameters/info_string:

                               

                              2.) WL commands working:

                                    $ wl ver

                                     $ wl bands → OK

                                    

                                    $ wl channels

                                  

                                     $ wl txpwr1 -q 20 -o

                                   

                                * Note: Others commands works too and take effect as for example: wl band, wl country, wl channel, wl mpc 0, wl up, wl isup.

                               

                              3.) Examples of WL commands not working:

                               

                                   $ wl dump

                                    

                                    $ wl country ALL

                                   

                                    $ wl pkteng_start 00:11:22:33:44:55 tx 20 1500 0

                                   

                                     $ wl pkteng_stats

                                   

                                    $ wl nvram_dump

                                   

                                * Note: Others commands also not work.

                               

                              4.) To recieve compatible with wlx86 Manufacturing FW from Cypress.

                              5.) To install received Firmware:

                              • Put FW ‘brcmfmac43340-sdio.bin’ in /etc/firmware/ (with permision) and remove original FW fw_bcmdhd.bin:

                                 

                               

                              • Modify ‘bcm43341.conf’, comment original FW path line:

                                   

                                            

                              • Modify driver configuration reference to FW pathbcm4334x.conf’, from the old FW to the new Manufacturing FW:

                                   

                                • Before:

                                  

                                • After:

                                  

                              6.) Reboot Device.

                              7.) Try wl Commands:

                                        *NOTE: First enable interface wlan0 → $ ifconfig wlan0 up

                              • WL Commands Working:

                                         $ wl ver

                                      

                                * Firmware in use looks like the Test FW version

                                         $ wl country ALL

                                        

                               

                                         $ wl txpwr1 -q 50 -o

                                         

                                          $ wl nvram_dump

                                              …………………….

                                                     

                               

                               

                               

                               

                               

                               

                               

                               

                               

                               

                               

                               

                               

                               

                               

                               

                               

                               

                               

                               

                               

                               

                               

                               

                               

                               

                               

                               

                               

                              • WL commands Not Working:

                                              $ wl pkteng_start

                                    * NOTE: At Spectrum Analyzer we as well not detected any Wi-Fi Signal being emited.

                              • 12. Re: CYW43340: FCC Wi-Fi test. wl tool. Return 'wl: Unsupported'
                                MuraliR_36

                                Hi BeCa_4374986

                                 

                                As i observed, it appears that the wl pkteng_start is the command that's not working.

                                To enable this, a list of commands needs to be executed as mentioned in /43xxx_Wi-Fi/libraries/test/wl_tool/scripts

                                I'll be writing an example for 802.11n taken from /43xxx_Wi-Fi/libraries/test/wl_tool/scripts/tx_80211n_start.bat . You need to do the changes as per your requirement.

                                This needs to be done as we need to ensure that the watchdog timer doesn't interfere with the pkteng_start functionality.

                                 

                                wl down

                                wl country ALL

                                wl band b

                                wl chanspec -c 11 -b 2 -w 20 -s 0

                                wl mpc 0

                                wl ampdu 1

                                wl bi 65000

                                wl frameburst 1

                                wl rateset 11b

                                wl up

                                wl txant 0

                                wl antdiv 0

                                wl nrate -m 7 -s 0

                                wl phy_watchdog 0

                                wl disassoc

                                wl phy_forcecal 1

                                wl phy_activecal

                                wl txpwr1 -1

                                wl pkteng_start 00:90:4c:aa:bb:cc tx 40 1000 0

                                 

                                Thanks,

                                Murali

                                1 of 1 people found this helpful
                                • 13. Re: CYW43340: FCC Wi-Fi test. wl tool. Return 'wl: Unsupported'
                                  BeCa_4374986

                                  Hello  MuraliR_36

                                   

                                  This sequence is working for me.

                                  I only had to change command 'wl nrate -m 7 -s 0' for 'wl nrate -m 4 -s 0', because the original returned 'wl: Not in Range'.

                                  With this change the sequence is working and I see on spectrum analyzer the continuous transmission.

                                   

                                  I have find the scripts examples to use that you have refered to. I have installed Wiced Studio 6.4.0 and scripts are on '/43xxx_Wi-Fi/libraries/test/wl_tool/scripts' as you indicated.

                                   

                                  If you have some wl manual or extra documentation to help for preparing tests it would be great.

                                  Anyway unless you find out some mistake that I don't realize; I think that original issue is solved.

                                   

                                  Thanks for your support.